I have Swiper1 version 8.007.013 dated 5/24/2018 on my Galaxy S7. When I try to use the Swiper1 unit, I get "Connecting to Swiper1, please wait..."...