Announcement

Collapse

Information Needed

See more
See less

Email not sending - again

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Email not sending - again

    This appears to another instance of email not being sent. Would you please escalate this? I have been apparently given inaccurate information and my attempts to get assurances of oversight have failed. How do we fix this permanently?


    In a prior thread, I was told that clicking on the "Send Email" button will make email go out immediately, even when the job isn't running. Sadly, I had a reason to put this to the test and found it not to be the case.

    In the same thread, I was told that my C&P would keep an eye on this issue. I have seen no notifications on this topic. May I have contact information for the brain connected to the eyeball?

    I asked whether there was any monitoring in place for the email sending job. I received no answer and the job apparently has failed again. How is it being monitored? What is the result of that monitoring?

    You have been granted access for 1 week.

    In the event "Introduction to Intimacy March 26, 2022 Online", the confirmation email is set to go out immediately. No email has gone out yet, despite several registrations. Clicking on the "Send Email" button only produced a message that they had been "submitted for broadcast" .The email queue is still empty several hours after a registration was submitted via box office.

    So, the images I am including are: showing registrations:


    1 - Click image for larger version

Name:	2022-03-22-1 registrations.png
Views:	65
Size:	120.8 KB
ID:	63416


    2 - confirming the email settings are active, and Immediately ( the event is set to "Active" but I'm not showing that here)


    Click image for larger version

Name:	2022-03-22-2 email settings.png
Views:	35
Size:	72.7 KB
ID:	63417


    what I see after I click the "Send Email" button

    Click image for larger version

Name:	2022-03-22-3 email submitted for broadcast.png
Views:	35
Size:	113.0 KB
ID:	63418


    the email log hours later

    Click image for larger version

Name:	2022-03-22-4 email blank log.png
Views:	35
Size:	64.7 KB
ID:	63419



    Bob

  • #2
    Good day @BobD

    Sorry for the inconvenience. We are continuously monitoring your instance and finally, we have caught the culprit. The reason for not firing the Emails is because the C&P Account Number is missing from the Event object i.e "C&P Event Email Level Junction Object (C&P Event)" which is required to fire the Registration Emails.

    Click image for larger version

Name:	Account Junction.jpg
Views:	35
Size:	94.2 KB
ID:	63423

    By default, the C&P Account Number will be added to that object when the Event is created. It looks like you have cloned most of the Events from the one which doesn't have the C&P Account Number in the "C&P Event Email Level Junction Object (C&P Event)" (Maybe someone manually deleted it from the source Event) which is why the emails are not firing for most of your Events.

    We have fixed a couple of Events which you have also included in the post and the Emails are fired successfully. There are still some Events which need to fix it.

    In order to fix the issue, go to the Email Templates > Edit > Save. This will add the C&P Account Number to the following Object of that Event Template: "C&P Event Email Level Junction Object (C&P Event)".

    Click image for larger version

Name:	Email Template.jpg
Views:	28
Size:	98.0 KB
ID:	63424

    If you want us to fix it for all of your Events, please let us know.
    Regards,
    Click & Pledge Support Department

    On Salesforce? Help us by rating our app: Click & Pledge Donor Management on AppExchange

    Join us @ the educational webinars: https://clickandpledge.com/webinars/
    Live Support available Join between 3:00 - 3:30 p.m. ET Monday - Thursday: https://clickandpledge.com/webinars/
    Are you on Salesforce? Join us at the Power of Us Hub: https://powerofus.force.com/0F980000000CjpC

    Comment


    • #3
      This is definite progress, welcome news and I am still confused.

      For this type of event in particular, each of the email templates has some part that is hand edited after cloning, so I know they all were edited and saved after creation.

      When I look at the template used to create the event ("Introduction to Intimacy - Template") , there is an account number associated with the event in Basic Information.

      When I look at the "C&P Event Email Level Junction Object" records, none of them have an entry in the C&P Event.
      Click image for larger version

Name:	2022-03-23-1 Event Email Level Object.png
Views:	32
Size:	40.3 KB
ID:	63426

      I have the sense that I am not understanding something and am looking in the wrong place.


      Bob

      Comment


      • #4
        I apologize, I have shared the correct image but the name I specified is wrong. It is "C&P Event Email Account Junction". However, I have discussed with our developers and they concluded that if you have edited the Email Templates then it must create the RecordID for the "C&P Event Email Account Junction" object.You might have edited the email templates in the standard layout instead of editing them in Event Management UI which is why it is not updated the RecordID for that object.

        Would you please try to edit the Email Template for other Events which doesn't have RecordID and let us know if that didn't create the RecordID for the "C&P Event Email Account Junction" object?
        Regards,
        Click & Pledge Support Department

        On Salesforce? Help us by rating our app: Click & Pledge Donor Management on AppExchange

        Join us @ the educational webinars: https://clickandpledge.com/webinars/
        Live Support available Join between 3:00 - 3:30 p.m. ET Monday - Thursday: https://clickandpledge.com/webinars/
        Are you on Salesforce? Join us at the Power of Us Hub: https://powerofus.force.com/0F980000000CjpC

        Comment


        • #5
          That was interesting. My sense is that the issue was in the code that added RecordID to the "C&P Event Email Account Junction" object.

          My reasoning is that:
          • Per your advice, I found a "C&P Event Registration Email" record that didn't have a C&P Email Account Junction. I went into the "C&P Event Management" UI, opened and resaved the email template. When I looked again at the "C&P Event Registration Email" record, it then showed C&P Email Account Junction related record.
          • When I looked at the body of that particular email, I saw that it had been customized (added a Zoom meeting link) after the Event had been created, so I know the email got edited and saved after the event was created.
          • The ONLY way I edit those emails is to go through the "C&P Event Management" UI. I am the only person doing this and I recall doing this particular batch. So, I am very confident that we didn't avoid using the "C&P Event Management" UI.
          • I have been using the same method for creating these events for many months. I have a template event, I use the Events Import function to upload a bunch of events and then I hand edit the email to include the Zoom link (which is different for each event) in the emails.
          • For the same process to start producing different results ( accounts not linked) ,something must have changed in either the code or the underlying template events. Since each email gets hand edited, I don't think a changed in the underlying template email is the cause.
          It looks like the method for me to identify the broken records is pull a list of all event email records for future events and see if there is no corresponding related record in the "C&P Event Email Account Junction". That is a way to identify what is currently broken, but it is more work than I would prefer to add in to the process of creating new events. In particular, it isn't something I can easily train less technical marketing staff to do.

          In short, it looks like we have a way to identify Registration emails which are broken, but we don't understand how they became broken.

          Comment


          • #6
            I went through and found all the C&P Event Registration Email records for future events (there were no templates that had an issue) that didn't have a C&P Event Email Account Junction entry, re-saved them and then ran the query again. For now, things look ok.

            Since the account number does not change from the template, I am not loading it in the CSV file for the Events Import process. I know that shouldn't matter. Does it in fact matter?

            Comment


            • #7
              Bob,

              It is not an issue with the import process, we have tested that. However, we are trying to replicate the issue in our test instances to find in which case the Email Account Junction Object missing the RecordID.
              Regards,
              Click & Pledge Support Department

              On Salesforce? Help us by rating our app: Click & Pledge Donor Management on AppExchange

              Join us @ the educational webinars: https://clickandpledge.com/webinars/
              Live Support available Join between 3:00 - 3:30 p.m. ET Monday - Thursday: https://clickandpledge.com/webinars/
              Are you on Salesforce? Join us at the Power of Us Hub: https://powerofus.force.com/0F980000000CjpC

              Comment

              Working...
              X