Announcement

Collapse

Information Needed

See more
See less

Authorization Required Issue

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Kofo
    replied
    Ok. Thank you for this thorough response. I'll update my team.


    Originally posted by Support.Department View Post
    Good day Kofo,

    I see the problem.

    You are using iframe in your site and our event registration form uses a cookie to keep track of the real-time inventory. When someone adds an item the cookie tracks & deducts the inventory in Salesforce so another person cannot purchase the item at the same time.

    The problem is Safari & Opera block third party cookies by default whereas Chrome, Firefox, and IE allow it by default as is shown here: https://www.apple.com/safari/

    [ATTACH=CONFIG]1679[/ATTACH]

    Of course the problem started when Google took advantage of something that Apple did not appreciate: http://www.zdnet.com/article/google-...bypass-charge/

    You may want to ask your user to use the other browsers that support standard browser features.

    In General Apple & Microsoft believe in open standards as long as it is their standard.

    What we are going to do in the next release is to add an option for not tracking inventory in real time and if selected we won't enable the cookie. Of course there is a sacrifice to be made with this since inventory may now exceed the available inventory if people are registering at the same time.

    Based on what you have described I am 99.9999% certain that your user is using Safari.

    I hope the explanation makes sense. Let us know if we can be of any further assistance.

    Leave a comment:


  • CnP.Support
    replied
    Good day Kofo,

    I see the problem.

    You are using iframe in your site and our event registration form uses a cookie to keep track of the real-time inventory. When someone adds an item the cookie tracks & deducts the inventory in Salesforce so another person cannot purchase the item at the same time.

    The problem is Safari & Opera block third party cookies by default whereas Chrome, Firefox, and IE allow it by default as is shown here: https://www.apple.com/safari/

    Click image for larger version

Name:	2492-Safari-cookies.jpg
Views:	1
Size:	71.6 KB
ID:	15698

    Of course the problem started when Google took advantage of something that Apple did not appreciate: http://www.zdnet.com/article/google-...bypass-charge/

    You may want to ask your user to use the other browsers that support standard browser features.

    In General Apple & Microsoft believe in open standards as long as it is their standard.

    What we are going to do in the next release is to add an option for not tracking inventory in real time and if selected we won't enable the cookie. Of course there is a sacrifice to be made with this since inventory may now exceed the available inventory if people are registering at the same time.

    Based on what you have described I am 99.9999% certain that your user is using Safari.

    I hope the explanation makes sense. Let us know if we can be of any further assistance.

    Leave a comment:


  • Kofo
    replied
    ok. I've added the value.

    Leave a comment:


  • Kofo
    replied
    1. I have no idea what browser she was using. Does this issue present itself on particular browsers?
    2. I believe she may have been accessing the form via an email we sent.



    Originally posted by Support.Department View Post
    Good day!

    We replicated the event in our instance and tested it. There are many registrations in your system that are successful. We have to figure out what is different for this user.

    Please let us know the answer to the following questions:
    1. Do you know what browser your client is using?
    2. What is the link to your registration form? - where are people going to register?

    Leave a comment:


  • CnP.Support
    replied
    Good day!

    One other observation:

    You are mapping the lead source to a value that is not available in your lead source values.

    Please see the following:

    in th field mapping you are mapping lead source to: 2015Gala
    Click image for larger version

Name:	2492-LeadSource.jpg
Views:	1
Size:	34.7 KB
ID:	15696


    In your lead source available values the 2015Gala is not available.
    Click image for larger version

Name:	2492-LeadSource-Value.jpg
Views:	1
Size:	38.4 KB
ID:	15697

    this can cause error.

    Please add that value to your list of lead source values.

    Let us know the answer to the previous questions as well.

    Leave a comment:


  • CnP.Support
    replied
    Good day!

    We replicated the event in our instance and tested it. There are many registrations in your system that are successful. We have to figure out what is different for this user.

    Please let us know the answer to the following questions:
    1. Do you know what browser your client is using?
    2. What is the link to your registration form? - where are people going to register?

    Leave a comment:


  • Kofo
    replied
    Hello,

    I just received another message from the same donor and she reports experiencing the same issue trying to purchase a ticket 10 minutes ago.

    She reports getting the "Authorization Required" message after entering "1" next to the $500 level and hitting continue.

    Also, I have not received any test transactions from your end.

    Leave a comment:


  • Kofo
    replied
    ok, thank you.

    Leave a comment:


  • CnP.Support
    replied
    Good day!

    Thank you for your prompt reply.

    We will clone the event and do several test transactions to check what is happening. You may receive test receipts.

    We will keep you posted.

    Leave a comment:


  • Kofo
    replied
    The donor said she was trying to purchase a ticket at the $500 level.

    Leave a comment:


  • CnP.Support
    replied
    Good day!

    The package was updated earlier. We could not duplicate the error but the upgrade and post installation is done.

    Do you know which level was being registered when the error was encountered.,

    Leave a comment:


  • Kofo
    replied
    Hello,

    I noticed that you updated a few C&P packages. Does this mean the issue is resolved? I'd like to have confirmation so that I can update the donor and our ED.

    Leave a comment:


  • Kofo
    replied
    Thank you.

    I have granted you access.

    My org ID is: 00Di0000000e51m

    Leave a comment:


  • CnP.Support
    replied
    Good day!

    This means the post-installation is not complete. A certain field in your registration form does not have the right permissions for the "Guest" user.

    If you grant us login access we will review & fix it for you.
    Please make sure to post your organization name & the Salesforce Organization ID so we know how to locate your instance. As part of the process we will also upgrade you to the latest instance of our applications. If you don't wish to be upgraded please let us know otherwise we will update your instance.

    Leave a comment:


  • Kofo
    started a topic Authorization Required Issue

    Authorization Required Issue

    Hello,

    I had a donor attempt to purchase a ticket last night and she received the following message:

    Authorization Required

    You must first log in or register before accessing this page.
    If you have forgotten your password, click Forgot Password to reset it.


    Can you help me figure out why this is happening and how to stop it?
Working...
X