Announcement

Collapse

Information Needed

See more
See less

Request to help with Events upgrade in SF

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Request to help with Events upgrade in SF

    It looks like I will need your expertise to upgrade Events from v.26000 to v.31018 for C&P Account 26003/org ID 00DF00000005zU1. When I performed the upgrade, I received the message: Salesforce has blocked this package upgrade because the new package version removes some Apex code....etc (you've seen it before). Perhaps there must be a prerequisite version in between that I missed.
    BTW, this upgrade was prompted today because of an error we are now receiving when we attempt to access Events pkg in SF:
    " Map key Active Events not found in map. Error is in expression '{!subTab['Active Events']['Active Events'].display=='true'}' in component <apexutputLink> in page cnp_paas_evt:activeeventpage".
    The active URL for this page has not changed to my knowledge.
    Many thanks for your attention.

  • #2
    I backed up a step and installed 2.6000.22 successfully. We are no longer getting the Map key error.

    Comment


    • #3
      Good day!

      Yes- the release requires 2.6000.22 and we have added you to the queue for update. Once 2.6000.22 is installed then the 3.x release may be installed. This is pointed out in the release notes: http://forums.clickandpledge.com/for...e-event-3-1017

      It is best if we review your post-installation.
      Regards,
      Click & Pledge Support Department

      On Salesforce? Help us by rating our app: Click & Pledge Donor Management on AppExchange

      Join us @ the educational webinars: https://clickandpledge.com/webinars/
      Live Support available Join between 3:00 - 3:30 p.m. ET Monday - Thursday: https://clickandpledge.com/webinars/
      Are you on Salesforce? Join us at the Power of Us Hub: https://powerofus.force.com/0F980000000CjpC

      Comment


      • #4
        I installed Events 2.6000.22. Then I installed the most recent upgrade 3.1018. Previously, I'd successfully installed PAAS 9.1014. I System Administrators have access. Two of them using Events today complained of long wait times for saves and screen refreshes. They are using Macs but are not in the same location. I tried on a pc and the saves do not seem slow. They said the screen looks like its saving for 10 mins or more but if the open up a new browser the saves are there. Have you had any instances of the upgrades not doing well on Macs? The C&P Account 26003/org ID 00DF00000005zU1 and you should still have access to it. I would appreciate a quick look-see, especially as to the upgrade.

        Comment


        • #5
          Good day @Bia,

          What is the link to your event?
          Regards,
          Click & Pledge Support Department

          On Salesforce? Help us by rating our app: Click & Pledge Donor Management on AppExchange

          Join us @ the educational webinars: https://clickandpledge.com/webinars/
          Live Support available Join between 3:00 - 3:30 p.m. ET Monday - Thursday: https://clickandpledge.com/webinars/
          Are you on Salesforce? Join us at the Power of Us Hub: https://powerofus.force.com/0F980000000CjpC

          Comment


          • #6
            Internal link in salesforce is https://promise686--cnp-paas-evt.na1...uF0000000GVd7#
            As for the external site, it is https://promise686.secure.force.com/...0000000AKoTIAW
            But the issue seems to be in the setup interface. Very slow.

            Comment


            • #7
              More context on this upgrade problem: My users who are System Administrators (standard profile) are the ones where Events is locking up and not rendering correctly. My profile (a clone of System Administrator) has not issues with Events. But it may be because, during the upgrade from Events 2.6000.22 to to 3.1018, I chose to upgrade only System Administrators. I'd like to just go ahead and upgrade it for all users. Would I do that by upgrading from the AppExchange? The "About C&P Apps" Applications Installed page says I'm up-to-date. (Interestingly, the Class Library is missing, though....are you all including that with PAAS now?) MANY THANKS.

              Comment


              • #8
                Good day!

                We have resolved your issue. Version 2.6000.22 is a beta release and needs to be installed through the link we have provided in the release notes.

                A number of permission sets are available allowing granular permissions to be assigned to a specific user. You may want to review the permission sets as well.
                • PS-CnP-Event-All-Permissions
                Please review your instance & let us know if all is working.
                Last edited by CnP.Support; 10-06-2015, 09:12 AM.
                Regards,
                Click & Pledge Support Department

                On Salesforce? Help us by rating our app: Click & Pledge Donor Management on AppExchange

                Join us @ the educational webinars: https://clickandpledge.com/webinars/
                Live Support available Join between 3:00 - 3:30 p.m. ET Monday - Thursday: https://clickandpledge.com/webinars/
                Are you on Salesforce? Join us at the Power of Us Hub: https://powerofus.force.com/0F980000000CjpC

                Comment


                • #9
                  Thank you. Events (logged in as System Administrator) appears to be working. I also noticed that the Class Library is now showing. I will review the permissions, as well. Your attention to this is greatly appreciated. Good day!

                  Comment


                  • #10
                    Oh, I spoke too soon. I"d forgotten that I'd switched the user I logged in as to my (good) profile. I've reset her to System Admin and it is still messed. I will look at the permissions as you suggested.

                    Comment


                    • #11
                      Alas, I added my test user (System Administrator profile) to the PS-CnP-Event-All-Permissions and it still did not fix the problem. I am attaching a screenshots of an Event - Messages in edit mode. In my (good) login, which was not upgrade, the Sold out, Pre-start, Event Ended, Term&Conditions, thank you and Payment Declined boxes render fine. On the same pc, same brower, logged in as the System Admin, the edit mode boxes do not render (The Sold Out one does render correctly, but not the rest). This is just part of the symptoms. The other is that when you click on a nav-bar item, or try to save edtis, it grinds and grinds away. You eventually have to close the window. I think I screwed up by skipping that patch and now things are messed up. See attachment.

                      Comment


                      • #12
                        Good day!

                        We resolved the permission issue for user [email protected]

                        Which user are you having the problem with?

                        It seems like a non-admin user has installed the app and as such permissions are all messed up (for lack of a better technical word)!

                        Click image for larger version

Name:	Nonadmin user.jpg
Views:	22
Size:	55.6 KB
ID:	19651

                        Hope that helps.
                        Regards,
                        Click & Pledge Support Department

                        On Salesforce? Help us by rating our app: Click & Pledge Donor Management on AppExchange

                        Join us @ the educational webinars: https://clickandpledge.com/webinars/
                        Live Support available Join between 3:00 - 3:30 p.m. ET Monday - Thursday: https://clickandpledge.com/webinars/
                        Are you on Salesforce? Join us at the Power of Us Hub: https://powerofus.force.com/0F980000000CjpC

                        Comment


                        • #13
                          Thank you for making this work. Yes, the API user profile is on my user and I did the install. Is the only profile that can do the install the Salesforce standard System Admin profile? My profile is a clone of that and has all rights (including installing 3rd party apps.). Only diff is that the API user's pwd never expires. So, though that may be the reason, and the point is moot now that you've "saved the day/week/month", I wonder if the real reason is because the skipped upgrade of the patch may have been and issue. Oh, well, whatever the reason, thank you again! Good day!

                          Comment

                          Working...
                          X