Announcement

Collapse

Information Needed

See more
See less

How to Add a Device

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • How to Add a Device

    I installed the Swiper1 app on Salesforce, configured in C&P.

    On the Device Management section of Event Management, I do not see anywhere to "add a device".

    How do I add a device ?

  • #2
    Good day!

    You don't add a device in Salesforce - you simply approve what has been requested to be approved.

    Please go to your mobile device and go to Event Settings and request authorization. Once the request posts to Salesforce you may go and activate it.

    See the following image:

    Click image for larger version

Name:	Swiper1-Event-Device.jpg
Views:	1
Size:	23.7 KB
ID:	15357

    Please let me know if you need any additional help.
    Regards,
    Click & Pledge Support Department

    On Salesforce? Help us by rating our app: Click & Pledge Donor Management on AppExchange

    Join us @ the educational webinars: https://clickandpledge.com/webinars/
    Live Support available Join between 3:00 - 3:30 p.m. ET Monday - Thursday: https://clickandpledge.com/webinars/
    Are you on Salesforce? Join us at the Power of Us Hub: https://powerofus.force.com/0F980000000CjpC

    Comment


    • #3
      Thanks, still not working though.

      On my iPhone, in the app, (as described), under events, I request authorization and get a message "Please wait authenticating"

      Then, I log into Salesforce, go to Event Management, Devices and still see no devices.

      Please advise.

      Comment


      • #4
        In an effort to fix this, I deleted the connected app.

        Now when I try to add it back, I get this error.

        • The application name Swiper1 / Swiper1 has been used before. Use a new unique name for your application.


        So, I created another connected app, called it SwiperB, put the codes into click and pledge. They verify in ClickandPledge account, however I still get nothing on the Device Tab, and the iPhone still in "please wait authenticating" mode.

        The app is configured properly, since I get a connection verified from C&P settings, however I cannot authenticate a device still

        Please advise
        Last edited by elkiehound; 01-23-2014, 10:05 PM.

        Comment


        • #5
          Good day!


          The application name is not important so please set up the application per post installation and call it whatever you think is appropriate. The only important thing is when we try to connect to Salesforce for the app to respond back.

          We have seen the issue before when the user used for connection has SMS or IP restriction set. When you establish connection manually it is coming from your own IP address and if you are using SMS verification the system will still work since the IP address has not changed. With mobile phone the IP is different and if the user used for connection with Click & Pledge can't connect directly through a different IP without SMS verification Salesforce will reject it.

          May I ask you to check your policy and see if for the user the mobile phone has been set? This is the same user that you have used in the Click & Pledge > 3rd Party > Salesforce.

          Also ensure that IP security is not set for the application and that IP Security Exclusion is selected. Please see this post: http://forums.clickandpledge.com/showthread.php?t=1583&page=2&highlight=salesforce

          This is ONLY one reason for the issue you are seeing- Swiper1 cannot connect to Salesforce. You can easily verify this by the following easy test:
          • In Swiper1 go to the Cash Register and add anything as item name and an amount (just a test item)
          • Go to the payment section and add the first and last name of a contact you have in Salesforce
          • Click on Salesforce Contact Lookup and see if you see that name show up.

          If the name does not show up Swiper1 cannot connect to Salesforce and Salesforce is refusing connection.

          Please try the above and let me know. If we can connect the rest is easy and should be seamless..

          our record shows that a similar question has been posted to the support department with ticket id: 18163 - Please use a single medium to get resolutions to the issues. Posting to the forum and support may delay in getting answers. Please verify which medium you wish to proceed with so we can close one case and continue with the selected medium.
          Regards,
          Click & Pledge Support Department

          On Salesforce? Help us by rating our app: Click & Pledge Donor Management on AppExchange

          Join us @ the educational webinars: https://clickandpledge.com/webinars/
          Live Support available Join between 3:00 - 3:30 p.m. ET Monday - Thursday: https://clickandpledge.com/webinars/
          Are you on Salesforce? Join us at the Power of Us Hub: https://powerofus.force.com/0F980000000CjpC

          Comment


          • #6
            My mobile phone was not in my Salesforce profile, so I added it. Still have problem.

            I did the test putting an time in the cart and looking up the contact in salesforce and it could not connect.

            So, it appears that Salesforce is refusing the connection.

            You mention checking that IP security is not on for the application, however the link that you provide makes no mention of this. Where do I check to see if the IP security is the root cause of this ?

            Comment


            • #7
              Good day!

              The Connection user - not your userid - the one that is used to connect Click & Pledge to Salesforce should NOT have SMS verification turned on. This user needs to have no restrictions:

              The application should also not be set up for IP limitations. See the IP access list below:

              Click image for larger version

Name:	Swiper1-Connection.jpg
Views:	1
Size:	120.6 KB
ID:	15358

              In the User profile make sure mobile phone and SMS is not activated. See image below:
              Click image for larger version

Name:	User_Mobile.jpg
Views:	1
Size:	23.2 KB
ID:	15359

              Please make sure that Swiper1 has access to your Salesforce account and nothing requires verification. The userid that is used in the Salesforce tab in the Click & Pledge portal has to have open access.

              If you still can't figure it out please grant us access and we will review your account.
              Regards,
              Click & Pledge Support Department

              On Salesforce? Help us by rating our app: Click & Pledge Donor Management on AppExchange

              Join us @ the educational webinars: https://clickandpledge.com/webinars/
              Live Support available Join between 3:00 - 3:30 p.m. ET Monday - Thursday: https://clickandpledge.com/webinars/
              Are you on Salesforce? Join us at the Power of Us Hub: https://powerofus.force.com/0F980000000CjpC

              Comment


              • #8
                I verified that the admin account does not have a mobile number and there are no IP restrictions.

                Please login and fix this. Account - 00DG0000000ic8e

                Our event is tomorrow, so this is urgent.

                Comment


                • #9
                  Good day!

                  your installations are one version behind. Is it OK for us to upgrade you before we start figuring out what is going on with your login?
                  Regards,
                  Click & Pledge Support Department

                  On Salesforce? Help us by rating our app: Click & Pledge Donor Management on AppExchange

                  Join us @ the educational webinars: https://clickandpledge.com/webinars/
                  Live Support available Join between 3:00 - 3:30 p.m. ET Monday - Thursday: https://clickandpledge.com/webinars/
                  Are you on Salesforce? Join us at the Power of Us Hub: https://powerofus.force.com/0F980000000CjpC

                  Comment


                  • #10
                    Yes as long as it does not effect our events setup. The event is tomorrow

                    Comment


                    • #11
                      Good day!

                      Something in your Salesforce instance is blocking connection. We have been trying to connect but can't.

                      We cannot test the Salesforce Swiper1 Connection in the portal. Would you please login to the Portal and go to Account Info > 3rd Party > Salesforce Swiper1 and click on Verify. Let me know if that verifies.

                      I just want to make sure that it verifies (click on the verify button and ensure that the message shows "Connected") since we have no way of checking considering we don't have your userid & password.
                      Regards,
                      Click & Pledge Support Department

                      On Salesforce? Help us by rating our app: Click & Pledge Donor Management on AppExchange

                      Join us @ the educational webinars: https://clickandpledge.com/webinars/
                      Live Support available Join between 3:00 - 3:30 p.m. ET Monday - Thursday: https://clickandpledge.com/webinars/
                      Are you on Salesforce? Join us at the Power of Us Hub: https://powerofus.force.com/0F980000000CjpC

                      Comment


                      • #12
                        Yes it is verified In Click and pledge it shows as "connected"

                        Comment


                        • #13
                          Good day again..

                          This is most confusing.. I reviewed your account and can't match the Consumer Key and Consumer Secret with what is in Salesforce for your account. The two values don't match at all.

                          Are you sure you have copied and used the correct information with your Salesforce Swiper1 connection?

                          Please see the following:

                          In Salesforce the following is provided for the Consumer Key & Secret:

                          Click image for larger version

Name:	Salesforce_Info.jpg
Views:	1
Size:	98.4 KB
ID:	15360

                          In Click & Pledge the following has been entered:

                          Click image for larger version

Name:	Portal_Swiper_Info.jpg
Views:	1
Size:	79.7 KB
ID:	15361

                          Just looking at the two values start and end shows the numbers don't match.

                          In Click & Pledge I reviewed account #: 27833
                          In Salesforce the Organization ID is: 00DG0000000ic8e

                          Please confirm that the above information is correct. There is no way that the Salesforce Swiper1 can connect to Salesforce considering the two values don't match.
                          Regards,
                          Click & Pledge Support Department

                          On Salesforce? Help us by rating our app: Click & Pledge Donor Management on AppExchange

                          Join us @ the educational webinars: https://clickandpledge.com/webinars/
                          Live Support available Join between 3:00 - 3:30 p.m. ET Monday - Thursday: https://clickandpledge.com/webinars/
                          Are you on Salesforce? Join us at the Power of Us Hub: https://powerofus.force.com/0F980000000CjpC

                          Comment


                          • #14
                            Good day!

                            May I ask that you please verify the following information. The account that you have used for Salesforce connection is the following:

                            Click image for larger version

Name:	Salesforce_Connection.jpg
Views:	1
Size:	79.9 KB
ID:	15362

                            Salesforce Organization ID: 00DG0000000ic8e

                            When I login to that Salesforce Instance the Consumer Key & Secret are as posted in the previous post. The one you have added to your account does not match the values for this account. The only way that you can get the connection verified is that you are logging into a different Salesforce account when you click on Verify.

                            I might be wrong but we have reviewed these settings and we are simply confused since nothing matches and yet you say it verifies.

                            Would you please click on the Verify button for the 3rd Party > Salesforce Swiper1 tab and let me know if you see "Verified" again.
                            Regards,
                            Click & Pledge Support Department

                            On Salesforce? Help us by rating our app: Click & Pledge Donor Management on AppExchange

                            Join us @ the educational webinars: https://clickandpledge.com/webinars/
                            Live Support available Join between 3:00 - 3:30 p.m. ET Monday - Thursday: https://clickandpledge.com/webinars/
                            Are you on Salesforce? Join us at the Power of Us Hub: https://powerofus.force.com/0F980000000CjpC

                            Comment


                            • #15
                              Ok, it appears to be working now. Thanks.

                              Comment

                              Working...
                              X