Announcement

Collapse

Information Needed

See more
See less

swiper1 not seeing any events

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Neely
    replied
    Thank you. That worked. I can now see all of my active events and can check patrons in and out. Hands down, CnP has the BEST tech support.

    Thank you and Kamran as well!
    Neely

    Leave a comment:


  • CnP.Support
    replied
    Good day Neely,

    We found out the issue. You had double quotes in your event name and it was causing an issue with the communication with the Swiper services. We replaced the " with ' (single quote) and it fixed the communication.

    We are going to block double quotes (") in the next release to ensure this does not happen again.

    Please test it and let us know if it is working now.

    Leave a comment:


  • Neely
    replied
    Here are the screen shots (jpg and png....had to blur the personal details in photoshop...sorry for delay.




    Leave a comment:


  • CnP.Support
    replied
    Please grant us access and let us know the Organization ID for Salesforce so we can review your setting.

    Leave a comment:


  • CnP.Support
    replied
    Let's check one more thing.

    Has the event published date started? Meaning the Publish Date is in the past?

    Leave a comment:


  • Neely
    replied
    Yes, this is set. The devices are enabled and the events are checked....will send screen capture in a few min. End dates are set as well.
    Last edited by Neely; 04-06-2014, 12:40 PM.

    Leave a comment:


  • CnP.Support
    replied
    Great.

    Now let's make sure the event is checked with the user that has authorized the device.

    Click image for larger version

Name:	2014-04-06 16.28.35.jpg
Views:	1
Size:	5.6 KB
ID:	15439

    When you go to Salesforce Event Management Device Manager you should see the user and its permission.

    Is the event checked? Also make sure your user is active and the end date are all set correctly.

    Click image for larger version

Name:	2014-04-06_12-30-45.jpg
Views:	1
Size:	133.7 KB
ID:	15440
    are these all set up correctly?

    Leave a comment:


  • Neely
    replied
    Yes, the app does locate the contact. I tried 5 contacts that I know are in Salesforce and all 5 were found. I did this on both my new HTC One (M8) and my iPad 2s. Thank you.

    Neely

    Leave a comment:


  • CnP.Support
    replied
    Good day @Neely,

    We need to do a simple test first.

    - Go to New Transaction and add an item
    - Go to the next step for making the payment and add a name that is in your Salesforce instance
    - Click on Contact Lookup in Salesforce

    Does the app locate the contact?

    Click image for larger version

Name:	2014-04-06 14.55.30.jpg
Views:	1
Size:	29.8 KB
ID:	15438

    I want to make sure that Swiper1 can connect to Salesforce.

    Leave a comment:


  • Neely
    replied
    Swiper 1 Check In/Out See "No Active Events"

    Hi,
    I am having the same problem: I am using iPad 2s and when I try to use Check In/Out, I am getting a message that there are no active events. I have followed this thread and checked everything mentioned in this thread. I know Swiper1 is connected as I was able to complete some test transactions with the card reader. The devices are all enabled for the event as well as under the Device Manager menu. Please advise. I have already granted login access. Thank you!

    Neely

    Leave a comment:


  • CnP.Support
    replied
    Good day!

    We have confirmation that you are aware of the resolution and that your Swiper1 integration with Salesforce Events is working as expected. The following summarizes what actions we took and how the issue was identified. I would like to explain how Swiper1 <> Salesforce integration works and then explain the issues that had to be fixed in your account to resolve the reported issue.

    Swiper1 uses OAuth to communicate directly with Salesforce. All look-ups and event attendee list synchronizations are done directly with Salesforce. For OAuth to work the following has to be setup:
    The Salesforce user associated with the Click & Pledge <> Salesforce integration (http://forums.clickandpledge.com/content.php?r=183-How-to-Connect-ClickandPledge-to-Salesforce) has to have access through OAuth to login to Salesforce and interact with the account. The following Salesforce security features block such interaction:
    • SMS Login & verification [Administrative Setup > Users ]: If the mobile phone is added to the User being used for C&P connection, Salesforce will require SMS authentication prior to each connection.

      Click image for larger version

Name:	SMS_Authorization.jpg
Views:	1
Size:	14.1 KB
ID:	15351
    • Trusted IP Ranges [App Setup > Create > Apps > IP Ranges: The IP's listed here are the ONLY IP's allowed to connect and any other IP will be blocked. In a mobile setting the mobile device's IP will be used and will be different with each connection.

    After debugging all aspects of your account we realized that you had both SMS authorization and IP security enabled for the app & account. The connected user was being blocked trying to connect to the Swiper1 services.

    Click image for larger version

Name:	IPRanges.png
Views:	1
Size:	5.6 KB
ID:	15352

    The OAuth setup works when you connect C&P to Salesforce because you login to Salesforce directly and follow all steps to create the connection, including the SMS and logging through your defined IP ranges. Once you have established connection the Swiper1 needs to connect to your instance using the OAuth security variables and this is where the problem starts. The user will NOT be able to login to Salesforce since Salesforce requires it to come from the same IP ranges as well as verify it with SMS. Since mobile devices use the IP address of the mobile operator or the connected network, the IP mismatch will block them from automatically connecting to Salesforce.

    I hope the above provides an insight into why you could not review your events.

    Please let us know if we can be of any further assistance.

    Leave a comment:


  • CnP.Support
    replied
    Good day!

    It is hard for us to verify your connection since we don't have your userid & password.

    Based on all of our tests it appears that your account is not connected to Salesforce. Contact lookup does not work and event is not connecting to your instance.

    Is anyone available over the weekend that we can work with on this issue?

    Leave a comment:


  • CnP.Support
    replied
    Hi Again,

    May I ask that you go to Portal > account Info > 3rd Party > Salesforce Swiper1 and verify your connection to Salesforce?

    We are testing your account and it appears that it is not connected.

    Can you lookup a contact when you a transaction in Swiper1? I have tested your userid and the connection is being blocked by Salesforce.

    Leave a comment:


  • CnP.Support
    replied
    Good day!

    I reviewed your Salesforce account and see that you are registered with 2 devices where one of the devices shows NULL as the Device ID.

    Do you know why one of your devices has not posted its Mac Address or Device ID? Is it OK to delete that NULL device and test?

    Leave a comment:


  • mtyson@world-affairs.org
    replied
    it still says no events available. We would really like to get this working. please helpClick image for larger version

Name:	Screenshot_2014-01-17-14-42-34.jpg
Views:	1
Size:	5.7 KB
ID:	15350

    Leave a comment:

Working...
X