Announcement

Collapse

Information Needed

See more
See less

Contact not getting created

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • NiMSupport
    replied
    Hi,We did a bunch of stuff and something ticked it off and its working fine now. May be its because xmlsetting had 'Person Account' checked for some reason. I will try to use your support system if I run into the issue again.
    Thanks!

    Leave a comment:


  • CnP.Support
    replied
    Strange!

    If it works in the Sandbox it has no reason not to work in production.

    Please email us: [email protected] and request a session. One of our support engineers will call you soon and share the screen to see what is going on.

    Leave a comment:


  • NiMSupport
    replied
    Thanks!
    Unfortunately, this didn't solve the issue in Production.. Is it possible that some Salesforce permission settings are preventing the contact getting created? Any pointers will be greatly appreciated. In the meanwhile I will dig into the Salesforce permission settings as well.

    Leave a comment:


  • CnP.Support
    replied
    Glad to see it worked.

    Our updates address various issues that come up with NPSP upgrades and various configurations.

    It is always best to stay with the latest release. The link I sent you will always have the latest release. The system will also notify you if you subscribe to the thread for the latest updates.

    Please let us know how we can be of more assistance.

    Leave a comment:


  • NiMSupport
    replied
    Update: version 4.32 works fine in Sandbox.
    I am waiting on approval to update the Production version to 4.32 as well. Hopefully it will work.

    Thanks for the support!

    Leave a comment:


  • NiMSupport
    replied
    It says 'successfully transacted'.

    I then pointed the checkout pages to the sandbox instance which runs an even older version (4.13) and the 'contact' is getting created fine.
    I am going to update the Sandbox version to latest and see what happens. Thank you!

    Leave a comment:


  • CnP.Support
    replied
    Please click on C&P Data and check the posted XML. Scroll down and see if there is any message posted at the bottom of the XML page.

    The following is where you need to look:

    Click image for larger version

Name:	CnP_Data_Message.jpg
Views:	1
Size:	16.4 KB
ID:	15043

    Leave a comment:


  • NiMSupport
    replied
    Hi,

    Thank you so much for the quick response. Both 'Create a new Contact if Contact does not exist.' and 'Update Contact information if Contact exists.' are checked. Also, since the instance has Non-Profit Starter Pack, it is set up as mentioned here: http://forums.clickandpledge.com/content.php?269-NonProfit-Starter-Pack . However, the issue might be because of the version (can't say for sure though). I will try updating the version.

    Thanks

    Leave a comment:


  • CnP.Support
    replied
    Good day!

    Please make sure to install the latest release as listed here: http://forums.clickandpledge.com/showthread.php?481-Latest-Release-Features-amp-Alerts

    The issue can ONLY happen if the C&P Settings is set NOT to create contact. Have you checked the settings in the C&P Settings tab?

    see the following image:

    Click image for larger version

Name:	CnP_Settings.jpg
Views:	1
Size:	16.7 KB
ID:	15042

    Please double check and let us know if your setting is set as intended.

    Leave a comment:


  • NiMSupport
    started a topic Contact not getting created

    Contact not getting created

    I am setting up Click n Pledge checkout pages for one of our clients - they have version 4.21 installed. They have NPSP as well.
    The checkout forms(simple as well as advanced) are working fine and the data/transaction is getting passed on to Salesforce but 'contact' field is empty - in the sense, these donations don't create a new contact and keep the contact field empty. Is there something that I am missing in setting up the checkout pages?
Working...
X