Information Needed

See more
See less

Can't Update Custom Question Mapping

  • Filter
  • Time
  • Show
Clear All
new posts

  • Can't Update Custom Question Mapping

    I'm trying to update a custom question mapping in C&P Settings (Custom Mapping -> Custom Question Map sub-tab), but for some reason it’s not accepting my update. My goal is to change the Question on an existing mapping to match what’s coming into Salesforce in the CnP Data. I tried editing an existing mapping, and I tried adding a new one. I don't get an error, but neither does the Mapping get updated or added. It's the last mapping in the set - Object Opportunity, Field: In honor of / in memoriam, which is a text field.

    Org ID is: 00Do0000000agMP
    I have granted login access


  • #2
    Aha - I think I have figured it out. My userid had PS-CnP-PaaS-Connected-User-ONLY permission. I just added PS-CnP-PaaS-All-Permissionsand now I can update the Custom Question Mapping.
    I'm not sure why my user (SysAdmin profile) had Connected-User-ONLY permissions. Can you please clarify the use of Connected-User-ONLY. Is the following correct?:
    • Connected-User-ONLY should be assigned only to the userid that is used for the connection between C&P Connect and Salesforce.
    • All other users who work with C&P settings in Salesforce should have PS-CnP-PaaS-All-Permissions

    Last edited by snesson; 03-21-2021, 08:59 AM.


    • #3
      Good day @snesson

      Yes, that is correct.
      Click & Pledge Support Department

      On Salesforce? Help us by rating our app: Click & Pledge Donor Management on AppExchange

      Join us @ the educational webinars:
      Live Support available Join between 3:00 - 3:30 p.m. ET Monday - Thursday:
      Are you on Salesforce? Join us at the Power of Us Hub: