Announcement

Collapse

Information Needed

See more
See less

Ampersand dropped from custom questions

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • CnP.Support
    replied
    Good day!

    We just had an update to the Salesforce Integration Services (IaaS) that replaces "&" with "and" prior to posting to Salesforce.

    Please let us know if we can help with any other issues you may be experiencing.

    Leave a comment:


  • sum3
    replied
    This is a problem for us, as it means we may get a donor name wrong, which is a top priority. Can you replace ampersands with "and" until you're able to come up with a more elegant solution?

    Thanks

    Leave a comment:


  • CnP.Support
    replied
    Good day!

    Sorry for the inconvenience.

    The XML parser in Salesforce has problem with the "&" sign and as a result we had to remove it the post until a solution can be found. The ampersand is always a problem in programming especially with XML fields. Of course CDATA may be used but that presented other challenges in that environment.

    For now "&" signs are removed but we are looking for an elegant solution that may help us add it in a future release.

    Leave a comment:


  • sum3
    started a topic Ampersand dropped from custom questions

    Ampersand dropped from custom questions

    When an ampersand, &, is entered in a custom question value, the ampersand is not passed through to salesforce. It does, however, appear in the email receipt that is sent.
Working...
X