Announcement

Collapse

Information Needed

See more
See less

Autoresponder not triggering

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • CoralReefAlliance
    started a topic Autoresponder not triggering

    Autoresponder not triggering

    Hello,

    The email autoresponders for donations coming in online that are marked as a tribute gift are not being sent out, though ones for standard donations are. I was hoping someone could take a look since I couldn't see what might be wrong.

    I've granted account access, and a sample donation of where that should have occurred but didn't is here: https://na33.salesforce.com/0063900000sSd2z

    Many thanks!

  • CnP.Support.AM
    replied
    Good day @CoralReefAlliance

    I have discussed this with our developers and here is what they have concluded:

    In case of Blank condition, it will not satisfy the Not Includes condition as it requires some Value because in case of AND both the conditions should satisfy (Not Includes - Any or Blank).

    However, here is what they have suggested to set up for you:

    Condition: OR

    Not Includes: Payment pages

    Is Blank:

    Please set it as shown in below image and it should work in your case:

    Click image for larger version

Name:	Responder Condition.jpg
Views:	1
Size:	19.4 KB
ID:	39834

    Hope this helps. Please check and let us know if we can be of any further assistance.

    Leave a comment:


  • CoralReefAlliance
    replied
    Hello - thank you for this update, glad to know I was at least on the right track Would you be able to let me know when this has been fixed?

    Thanks!

    Leave a comment:


  • CnP.Support.AM
    replied
    Good day @CoralReefAlliance

    It should work as you have set now but as of now, the AND condition with "Not Includes" as well as "Any or Blank" doesn't work together. We have identified that in this case, the Blank Campaign is not working whereas any value in Campaign works. I have forwarded this to our developers to review and fix it.

    Sorry for the inconvenience.

    Leave a comment:


  • CoralReefAlliance
    replied
    Hey there - thanks for this insight!

    I'm hoping I can try and describe for you what we're trying to have happen with our autoresponders to come to a resolution.

    We set up another payment page for payments that require a different receipt and autoresponder. I set the values on that autoresponder (called "Payment Receipt" for reference) to only trigger when the campaign is "Payments Page". For the Default page, I edited the responder to fire when the campaign is not the payment page and is any or blank, as we have enough other campaigns that it would be inconvenient to add them all (screenshots attached). This doesn't seem to work either. Do you have any insights on how we can set the filters to get these separate autoresponders to work?

    Attached Files

    Leave a comment:


  • CnP.Support.AM
    replied
    Good day @CoralReefAlliance

    We reviewed and found that the condition didn't satisfy which is the reason the above autoresponder didn't fire.

    Please see:

    C&P Autoresponder:
    Click image for larger version

Name:	Responder.jpg
Views:	1
Size:	69.6 KB
ID:	39797 ​​​​​​​

    C&P Data:
    Click image for larger version

Name:	CnP Data.jpg
Views:	1
Size:	98.1 KB
ID:	39798

    Please note that in above case, there must be any value in Campaign instead of empty to satisfy the condition so that autoresponder will fire.

    Hope that helps. Let us know if we can be of any further assistance.

    Leave a comment:


  • CoralReefAlliance
    replied
    Hello, yes, it is the "Default Receipt"

    Leave a comment:


  • CnP.Support.AM
    replied
    Good day @CoralReefAlliance

    Would you please share the responder name you are expecting to fire for above transaction?

    Looking forward to hearing back from you.

    Leave a comment:

Working...
X