Information Needed

See more
See less

Cannot re-post from Connect after occasional post errors

  • Time
  • Show
Clear All
new posts

  • Cannot re-post from Connect after occasional post errors

    We've had 2 posting errors in the past week that we can't seem to re-post from Connect. Transactions 1611291457502072845 got a post error right after we had changed the password for the SF connection. We tried to re-post from Connect after re-establishing the connection. The re-post didn't give an error, but the transaction is still listed as Error in Connect, and it did did not come into Salesforce. Four days later, we got a post error from transaction 1612031137056547015 for no apparent reason. Again, we tried to re-post, but the transaction didn't come into salesforce and still says Error in Connect.

    The Org ID: 00DA00000009Qrj
    I have granted login access

    The org is using PaaS 9.4017, which is a bit old, and we're also encountering a known bug in that version ( However, we prefer not to upgrade until after the new year because of the large volume of transactions the client is receiving during the holiday season.

    Do you have any ideas on why the occasional transactions are getting post Errors and why those transactions do not re-post?


  • #2
    Good day snesson

    There is a custom trigger in the instance that is failing. The donor has entered her name in the email field of a custom question the custom trigger is failing and blocking us from inserting the record.

    Click image for larger version

Name:	2016-12-05_9-47-33.jpg
Views:	14
Size:	33.4 KB
ID:	29359

    Click image for larger version

Name:	2016-12-05_9-47-03.jpg
Views:	17
Size:	25.7 KB
ID:	29360

    The second order that had the issue has N/A as the email address so it is the same issue.

    Also- the client's instance is quite old and no longer supported. The client also will not be able to use any of the new Connect forms. We highly recommend that you update immediately. Of course we cannot force the client to update but the instance is no longer supported and should any issues arise the fix is to upgrade. The instance is 3 releases behind.

    Please let us know if we can be of more help.

    Click & Pledge Support Department

    Join us @ the educational webinars:
    Live Support- read more: