Announcement

Collapse

Information Needed

See more
See less

Recurring Donor not posting correctly.

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • CnP.Support
    replied
    Good day!

    Please note that you should NOT delete a Temp since the Self-Healing will run the C&P Data again and they will show up again. The self-healing constantly reviews your instance and the C&P Data to find inconsistencies. Deleting the Temp in the presence of C&P Data will re-create the Temp again.

    To delete any order number it is best to go to C&P Settings > Maintenance and delete the Order Number. Once the maintenance deletes the order number, it will remove all traces of it so the temp will not appear again.

    We simply took the order numbers and deleted them in the Maintenance. The temp should not re-surface.

    Hope that helps. Let us know if we can be of more help.

    Leave a comment:


  • dstephens
    replied
    Just wanted to remind you that the TCs are still there, thanks.

    Leave a comment:


  • dstephens
    replied
    When I processed them originally, they pushed through as closed lost properly, but then were back in the TC bin the next day.
    When I deleted them they went away and then showed up back in the TC bin the next day.
    When I went back to Connect, pushed them through again from there, and then processed the TCs, they went away, and then came back as TCs the next day.

    Like a wrinkled dollar bill in a vending machine. Every time you think you're about to get a snack, it just comes right back...

    Leave a comment:


  • CnP.Support
    replied
    Good day!

    "keep coming back"

    what do you mean? back from where?

    Leave a comment:


  • dstephens
    replied
    Just picked up some new Recurring Donors with TCs that keep coming back. I have deleted them, processed them, re-pushed them through from Connect but they persist.
    Order Numbers:
    161269581758542411845
    16125720947486797993

    They are both the 11th installment of their respective monthly donations, and they both were declined and they both appear to have bad email addresses associated with them.

    Thanks for your help.

    Leave a comment:


  • dstephens
    replied
    I have deleted the temps. Thanks for your help!

    Leave a comment:


  • CnP.Support
    replied
    Good day!

    These are NOT new temps. These temps are from the Event management that were ignored and were just sitting in the Event Temp. As the release note states, in the current release we have combined the Event Temp with the master Temp table and all records now show up together and may be filtered using the pull down menu at the top of the grid.

    Reviewing the data shows that the records have been deleted. See below:

    eg: 130305091709990 [ https://na14.salesforce.com/a06d0000...Kp=a06&srPos=0 ]

    Click image for larger version

Name:	CnP_Data.jpg
Views:	21
Size:	23.2 KB
ID:	21732

    The corresponding record does not exist

    Click image for larger version

Name:	Event.jpg
Views:	20
Size:	65.0 KB
ID:	21733

    & the Registrant ID:
    Click image for larger version

Name:	registrantid.jpg
Views:	20
Size:	55.6 KB
ID:	21734

    So the data has been deleted.

    If you want you can delete the temp or we can delete them for you as all references to these events & contacts are no longer in your instance.

    Leave a comment:


  • dstephens
    replied
    That looks great! Thank you for fixing the record. I will remember that the importer is not accurate for recurring donations. Thank you for clarifying on that.

    In addition to that issue it appears that this process (perhaps the updating of our version) has created a new issue. It appears like it has pulled in 9 older records to our Temporary Contacts. Upon reviewing all of them we receive:

    Attempt to de-reference a null object An unexpected error has occurred. Your solution provider has been notified. (CnP_PaaS_EVT)

    Could you review our TCs and see what the issue is there?

    Thanks!

    Leave a comment:


  • CnP.Support
    replied
    Good day!

    We resolved all the duplicates and pushed all missing transactions.

    Please review the record and let us know if there are any other issues.

    Leave a comment:


  • CnP.Support
    replied
    & one more point.

    It seems the data has been imported using the importer which does not support the hierarchy of the recurring. The data needs to be posted from Connect.

    We are working on fixing it and the solution is to delete the records and post them again one by one.

    Once we clean your posts we will post the data and resolve the issue.

    Leave a comment:


  • CnP.Support
    replied
    Good day!

    I am reviewing your instance & see a lot of duplicate posts with duplicate errors. We are trying to resolve and remove the duplicates but strangely I do not see the "Repost" button for the C&P Data. We need to delete and repost the data but seems some buttons are removed.

    One of our developers is reviewing your instance & we will get back to you shortly.

    Leave a comment:


  • dstephens
    replied
    Thanks for doing the update for us! Unfortunately though, the issue with the record is still there.

    Let me explain:

    This shows that there is a issue with the records being synced over. I have imported the donations as it instructs.
    Click image for larger version

Name:	Error.png
Views:	22
Size:	4.1 KB
ID:	21578

    This shows that the most recent transaction on the recurring record (from the link you provided above) is June 2015
    Click image for larger version

Name:	error2.png
Views:	21
Size:	2.1 KB
ID:	21579

    This shows that the next installment date is July 2015 on the recurring record
    Click image for larger version

Name:	error3.png
Views:	21
Size:	3.8 KB
ID:	21580

    This shows that the most recently imported transaction from that recurring feed is January 2016
    Click image for larger version

Name:	error 4.png
Views:	46
Size:	3.0 KB
ID:	21581

    All the transactions have been imported, but the recurring record didn't update.

    Sorry the images are blurry...

    Leave a comment:


  • dstephens
    replied
    Forgive me for some reason I missed the notifications of your replies! If you would like to upgrade us and see if that fixes this issue that would be great!

    Leave a comment:


  • CnP.Support
    replied
    Good day!

    I am a bit confused when reviewing your instance.

    This Order Number is in Salesforce: 132563914801234

    The C&P Data is missing so it must have been deleted. The transaction was paid on February 5, 2013

    The original transaction was a future date transaction set as recurring with the first order # being: 1302041229545554860 and posted on 2013-02-04 12:30:07.253

    Before we go any further- in the latest release of PaaS, 9.3x this issue will self correct. If you post a recurring out of sequence the single transaction posted will create a recurring family and then as you post the missing transactions they will auto-correct and populate. You are in release 9.1 and we are now on 9.3. If you want we can upgrade you now.

    Do you want us to push the master order number for you?


    The recurring family is at: https://cnp-paas.na14.visual.force.c...08d000000LIpI9

    If you go to the above link you will see all the transactions associated with this recurring family so it seems like it is working.

    Please review and let me know if you still have issues. I strongly recommend that you upgrade sooner rather than later.

    Leave a comment:


  • CnP.Support
    replied
    Good day!

    Is this your Salesforce Organization ID: 00Dd0000000eXib


    Leave a comment:

Working...
X