Announcement

Collapse

Information Needed

See more
See less

Virtual Terminal Issues

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • CnP.Support
    replied
    Good day,

    Yes- that field should always be blank.

    We have heard of Winter 2014 having an impact on this. This was reported by someone else after the upgrade on his instance:

    http://forums.clickandpledge.com/showthread.php?t=1415

    We are working with Salesforce on this trying to figure out why this is happening after the Winter 2014 upgrade. I think this is also related to your issue.

    Leave a comment:


  • mprcic@stand.org
    replied
    Got it, so the CnP_PaaS__Id__c field should be cleared for the other records we have with this issue, correct?

    Leave a comment:


  • CnP.Support
    replied
    Hi;

    Yes- something had replicated the wrong information when merged. Just keep that in mind that the Id field should be blank otherwise it will not redirect correctly.

    Leave a comment:


  • mprcic@stand.org
    replied
    Hi, thanks for the response! I am aware of the HideMemRenewalButtonLeft, it is a component that we use to dynamically display a button on certain object records based on criteria. It is something that is not otherwise possible on a standard SF Layout. I will work on reproducing the error message on the C&P VF page, I can't read it in the screenshot above.

    With regards to the merged/Contact Virtual terminal issue, what is the suggested fix? Merging is standard procedure with duplicate records... Does it appear that there was something wrong with this merge?

    Leave a comment:


  • CnP.Support
    replied
    Good day @MPrcic:

    One of our developers spent some time with your instance and figured out what is going on. The following lists the issues & our findings:
    • Contact Id for the virtual terminal: It seems that this record has been merged with another record. See below:


    Click image for larger version

Name:	Merged_records.jpg
Views:	1
Size:	64.9 KB
ID:	15304

    When one clicks on the Virtual Button the Contact Id is correct for the new person but Salesforce is redirecting it to the old Contact Id of the records prior to merging. The new ID is: 003E000000OYWSEIA5 but Salesforce is redirecting it to: 003E0000009a1fcIAA which we are guessing is the Contact Id of the original contact prior to the merge - this is just a guess since the new Id does not exist in your system. We have tested this in a test instance by merging 2 contacts and testing the virtual terminal button and it works fine but we can't figure out why with this contact the Contact Id redirects to a different Contact Id. As stated the Virtual Terminal button is pointing the correct Id. See the code below:

    <input value="Virtual Terminal" class="btn" title="Virtual Terminal" name="cnp_paas__virtual_terminal" onclick="navigateToUrl('/servlet/servlet.Integration?scontrolCaching=1&amp;lid=00bE 0000000cuKN&amp;eid=003E000000OYWSE&amp;ic=1','DETAIL');" type="button">

    Once it redirects to the VT the link changes to:

    https://cnp-paas.na9.visual.force.co...l?sfContactId=003E0000009a1fcIAA

    In earlier versions we had a field labeled "Id" in the Contact record which is no longer used. That field shows: 003E0000009a1fcIAA and in the presence of any value here Salesforce will use it as the reference Id. It appears that a value has been entered there since we don't update that field and it should be blank. We removed that value and it works now.

    • Campaign auto-complete not working: After reviewing all your settings we noticed the following


    Click image for larger version

Name:	Autocomplete_settings.jpg
Views:	1
Size:	55.5 KB
ID:	15305

    It appears that you have a component called: "HideMemRenewalButtonLeft" - if that component is disabled then the autocomplete works. The component does not have the JavaScript component that it needs & the page returns an error. The path for the layout: Build -> Home - >Home Page Layouts -> Dashboard Home Page Default

    The following is the error that is generated by that component. The following is the method:

    var result = sforce.apex.execute("EmailQueueLapsedMembersButton ","showHideButton", {string:subURL});

    and the error message is:

    Click image for larger version

Name:	Stand_Error_MethodMissing.jpg
Views:	1
Size:	20.4 KB
ID:	15306

    are you aware of this component? Is this a custom component that you have developed?

    Leave a comment:


  • mprcic@stand.org
    replied
    As I mentioned below, I have updated your login access.

    Leave a comment:


  • CnP.Support
    replied
    Good day!

    Great - would you please extend it for a week. Our developers are busy with the new release and we have to fit testing your platform in the middle of other tests. Giving us a little time will be quite helpful.

    Leave a comment:


  • mprcic@stand.org
    replied
    We will be upgrading soon, we have a testing and release cycle for all changes to Production and and if we're not waiting on specific C&P changes, we don't find enough value in immediately upgrading to every release. Also, given issues that new releases sometimes cause with existing functionality, it is often better to wait. I'm not aware of any reason that this issue should be version related, is there something I'm missing? I'm also updating your login access, for some reason I wasn't receiving emails that this thread was updated, and didn't realize you were waiting on me.

    Leave a comment:


  • CnP.Support
    replied
    Good day!

    It seems like access to your account has ended. Our developers are testing it and want to go back and forth between our test instance & your instance but have lost access.

    Would you please extend access for one more week.

    Leave a comment:


  • CnP.Support
    replied
    Good day!

    We have tried duplicating this issue with the latest release and can't duplicate it. You are using an older release - 7.3006 whereas the new version is 7.4027. Any reason why you have not upgraded to the latest release?

    Leave a comment:


  • CnP.Support
    replied
    Good day!

    No- please give us till Friday since the developer in charge of the VT is out till Friday. The issue has been assigned to her for review and testing.

    Sorry for the delay.

    Leave a comment:


  • mprcic@stand.org
    replied
    Any updates?

    Leave a comment:


  • mprcic@stand.org
    replied
    Ok, you're all set, ORG ID is :
    00DE0000000I5kW

    The Campaign field on VT doesn't bring up any Campaigns as you type, we have plenty that are active and don't show up, so I don't think that's the issue
    .

    Leave a comment:


  • CnP.Support
    replied
    Good day!

    Would you please check and see if your campaigns have ended? We only show the active / live campaigns that have not reached their limits and their dates are valid.

    We no longer sign-in to your accounts through the user. Please see the following for granting us access: http://forums.clickandpledge.com/showthread.php?t=1065

    Please let me know what you find out about campaign and when we have access.

    Leave a comment:


  • mprcic@stand.org
    replied
    The contact has a complete name. Her Id is: 003E000000OYWSEIA5

    I have reset the CnP User password so you should receive an email and can log in. As always, please do not make any changes in our instance. Thanks!

    Leave a comment:

Working...
X