Announcement

Collapse

Information Needed

See more
See less

Autoresponder only triggering for new contacts

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Autoresponder only triggering for new contacts

    Hi,

    My organization just migrated onto Click & Pledge within Salesforce (coming from Convio CommonGround). Most of the setup for Click & Pledge went smoothly, but I've hit an issue with the auto-responder. For some reason, it is only triggering to send the thank you email when a donation is submitted from a new donor/email address. When a donation is submitted by a contact that already exists in our Salesforce database, the autoresponder does not trigger. Can you help me fix this so the autoresponder will send for ALL donations from our web form, regardless of if it's a new or existing donor?

    Thanks for your help,

    Kestryl Lowrey
    IT and Database Manager
    Immigration Equality

  • #2
    Good day Kestryl:

    What you are describing does not make sense - it would have made more sense if it was working with existing and not new ones. A typical issue that people have is using the Semi-automatic mode and the new contacts go into the Temporary Contacts and will not send the autoresponder since they are not yet a contact. Once Temp contacts are processed then then autoresponder will be sent.

    Please give us access to your account so we can review your setting.
    Regards,
    Click & Pledge Support Department

    On Salesforce? Help us by rating our app: Click & Pledge Donor Management on AppExchange

    Join us @ the educational webinars: https://clickandpledge.com/webinars/
    Live Support available Join between 3:00 - 3:30 p.m. ET Monday - Thursday: https://clickandpledge.com/webinars/
    Are you on Salesforce? Join us at the Power of Us Hub: https://powerofus.force.com/0F980000000CjpC

    Comment


    • #3
      Hi,

      I just gave you login access. I agree it doesn't make sense. We're using semi-automatic mode. When a contact goes into temporary contacts, it does send the auto-responder when I process the contact to create a new contact-- and then it will continue to send the auto-responder if I submit another donation under that new contact. It's just not triggering for the existing contacts.

      Thanks for taking a look at my settings, I hope we can get this resolved!

      Comment


      • #4
        Good day @KLowrey:

        We have tested your account and our developer accounts and all works exactly as it should. We even created a fake AOL account to test your case since the user appears to have an AOL account. All worked perfectly.

        Please test it with any email other than an AOL account or one that you create. Our experience shows people with AOL accounts at times move emails to SPAM and overall AOL is not a very dependable service. Our highest incident of SPAM reporting of receipts is in AOL and one that constantly forces us to submit forms to AOL justifying the sending of receipts. I have no idea what these people report the receipt from a payment they have made as SPAM - but that is a different story.

        Have you tested this with another email provider? This issue has never never been reported and one that we just did an extensive test and based on all tests the autoresponder is going out perfectly for existing contacts.

        Please test it and let me know if you have issues with other users?
        Regards,
        Click & Pledge Support Department

        On Salesforce? Help us by rating our app: Click & Pledge Donor Management on AppExchange

        Join us @ the educational webinars: https://clickandpledge.com/webinars/
        Live Support available Join between 3:00 - 3:30 p.m. ET Monday - Thursday: https://clickandpledge.com/webinars/
        Are you on Salesforce? Join us at the Power of Us Hub: https://powerofus.force.com/0F980000000CjpC

        Comment


        • #5
          Hi,

          Unfortunately, this still doesn't appear to be resolved. You wouldn't have been able to duplicate it by creating a new AOL account, because that would have created a new contact in our system-- and the auto responder is triggering correctly for new contacts. It's just our contacts that existed previous to the installation of C&P that aren't triggering the auto-responder. I've tested this with multiple email providers (gmail, hotmail, custom domains). We received several donations from previously existing donors last night, and they received the C&P receipt, and the opportunity was created in Salesforce and linked to their contact record... but they didn't receive the nicely formatted auto-response/thank you letter that I set up using C&P Designer and the Auto-Responder settings. I've set myself to be bcc'd whenever an auto-response is sent, so I know nothing went out there... and when i checked the queue and the log, there was nothing waiting to be sent and no record of anything being sent yesterday.

          If you could look at it further in my account, I would appreciate it. You should still have login access to my account. Here are some examples of donations that didn't trigger the autoresponder yesterday:
          https://na8.salesforce.com/006C000000lXocd
          https://na8.salesforce.com/006C000000lXqDv
          https://na8.salesforce.com/006C000000lXqEy

          Thanks for your help!

          Kestryl

          Comment


          • #6
            Good day @KLowrey:

            The issue you are having is because the autoresponder you have set up does not have recurring set up as a condition. All the contacts you have identified have recurring transactions. The system will not send the autoresponder to these people for the transactions that are recurring because the setting simply is not set to have it sent.

            See the setting you have:
            Click image for larger version

Name:	Autoresponder_Setting.jpg
Views:	1
Size:	72.2 KB
ID:	15273

            Please review this and let us know if this solves your issue.
            Attached Files
            Regards,
            Click & Pledge Support Department

            On Salesforce? Help us by rating our app: Click & Pledge Donor Management on AppExchange

            Join us @ the educational webinars: https://clickandpledge.com/webinars/
            Live Support available Join between 3:00 - 3:30 p.m. ET Monday - Thursday: https://clickandpledge.com/webinars/
            Are you on Salesforce? Join us at the Power of Us Hub: https://powerofus.force.com/0F980000000CjpC

            Comment


            • #7
              Hi,

              Thanks, that does answer part of the question... but it's not triggering for single donations either. To test, I just personally submitted another single donation. You can see the opportunity that was created here: https://na8.salesforce.com/006C000000lXy5xIAC, but I didn't receive an autoresponder email for it. Is there something else in my settings that needs to be fixed? Right now, I have two different autoresponders set-- one for recurring transactions, and one for single transactions. Is there something else I need to do?

              Thanks,
              Kestryl

              Comment


              • #8
                Good day Kestryl,

                We reviewed your account but before we can do more testing we need your permission to run TEST transactions and follow the autoresponder. We know that the feature works flawlessly for everyone so it must be something local with your settings. Before we run test and pinpoint the issue we always ask for permission.

                In reviewing your account we noticed the following validation rule and we are wondering if this may have something to do with it.

                Click image for larger version

Name:	ValidationRule.jpg
Views:	1
Size:	19.6 KB
ID:	15275

                The nature of the validation rule is blocking emails and while we are not sure what it is doing without testing it we thought to bring this to your attention and see if you know what this validation rule is supposed to do.
                Regards,
                Click & Pledge Support Department

                On Salesforce? Help us by rating our app: Click & Pledge Donor Management on AppExchange

                Join us @ the educational webinars: https://clickandpledge.com/webinars/
                Live Support available Join between 3:00 - 3:30 p.m. ET Monday - Thursday: https://clickandpledge.com/webinars/
                Are you on Salesforce? Join us at the Power of Us Hub: https://powerofus.force.com/0F980000000CjpC

                Comment


                • #9
                  Hi,

                  Thanks for bringing that to my attention. That validation rule only applies to a specific contact record type, which our donate form would never be trying to create. I've deactivated that rule for now, but it shouldn't have been interacting with the auto-responder in any way.

                  You're welcome to run test transactions, as long as it won't impact the functionality of our live donate form. I do have a form set up in test mode here: https://imeq.secure.force.com/donatetest .

                  From my own testing, what I've seen is that contacts that are created new or processed through the Temporary Contact do trigger the autoresponder. It's only contacts that pre-exist our C&P installation that don't trigger it.

                  This morning, the autoresponder did fire for a recurring donation for a previously existing contact-- so it appears the recurring part of it is fixed! Now, just to solve the puzzle of the pre-existing contacts...


                  Thanks for your help,
                  Kestryl

                  Comment


                  • #10
                    Hi Kestryl,

                    We just tested your account and all worked perfectly. Here is the info:

                    - We first created a contact manually for: Account Verification
                    - We did a test transaction using your test page and received the autoresponder (see below).

                    We can't find anything wrong and all seems to work as designed. We used GMail for the email and received the autoresponder almost immediately.

                    Click image for larger version

Name:	Receipt.jpg
Views:	1
Size:	94.4 KB
ID:	15276

                    Please review the contact and the autoresponder list and let me know if you find this not representative of your issue.
                    Regards,
                    Click & Pledge Support Department

                    On Salesforce? Help us by rating our app: Click & Pledge Donor Management on AppExchange

                    Join us @ the educational webinars: https://clickandpledge.com/webinars/
                    Live Support available Join between 3:00 - 3:30 p.m. ET Monday - Thursday: https://clickandpledge.com/webinars/
                    Are you on Salesforce? Join us at the Power of Us Hub: https://powerofus.force.com/0F980000000CjpC

                    Comment


                    • #11
                      Hi,

                      That's consistent with what I've seen from other tests. New contacts (contacts created AFTER we installed Click & Pledge, whether created manually or through the form) seem to receive the Auto-Responder with no issues. It is only previously existing contacts (Contacts created in our Salesforce instance prior to 9/21/13) that are failing to trigger the auto-responder.

                      Are there any specific fields on the contact record that the auto-responder might be looking for, that might not be populated on our previously existing contacts?

                      Thanks for your help with this puzzle.

                      Kestryl

                      Comment


                      • #12
                        Good day!

                        What if we do a test that hopefully will settle the problem.

                        Can we go to an "old" contact and change his/her email to our email and test it?
                        Regards,
                        Click & Pledge Support Department

                        On Salesforce? Help us by rating our app: Click & Pledge Donor Management on AppExchange

                        Join us @ the educational webinars: https://clickandpledge.com/webinars/
                        Live Support available Join between 3:00 - 3:30 p.m. ET Monday - Thursday: https://clickandpledge.com/webinars/
                        Are you on Salesforce? Join us at the Power of Us Hub: https://powerofus.force.com/0F980000000CjpC

                        Comment


                        • #13
                          Sure, you can try that with my contact record (Kestryl Lowrey, https://na8.salesforce.com/003C000001Ieb66IAB). As you can see, I've made several donations in the past few days, using all of the different email addresses on my contact, and I haven't been able to get it to send the autoresponder for any of them.

                          Thanks for your help!

                          Comment


                          • #14
                            Hi,

                            We switched to a different donation form this morning, and it seems that the autoresponder is triggering now for all donations, regardless of new or existing contacts. So, it's resolved for now. It makes me think there must be something in the hidden fields for our old form that was preventing the autoresponder from triggering.

                            The only difference I could find between the forms is that our new form (the one that IS triggering the autoresponder for all donations) includes the following line:

                            input id="SendReceipt" type="hidden" name="SendReceipt" value="false"

                            and the old form (the one that was NOT triggering the autoresponder for all donations) was the opposite:


                            input id="SendReceipt" type="hidden" name="SendReceipt" value="true"

                            So... I'm thinking that maybe the "SendReceipt" input on the old form was preventing the autoresponder? Either way, it seems to be resolved now!

                            Thanks for all of you help!

                            Kestryl

                            Comment


                            • #15
                              Good day Kestryl,

                              No- that cannot possibly be the issue. SendReceipt in the FaaS form is for system receipts and Salesforce has nothing to do with that flag.

                              Salesforce Autoresponder triggers off of the XML that posts to the C&P Data. System receipts are sent through the API and are totally independent.

                              Did you change an existing contact's email to a GMail account?
                              Regards,
                              Click & Pledge Support Department

                              On Salesforce? Help us by rating our app: Click & Pledge Donor Management on AppExchange

                              Join us @ the educational webinars: https://clickandpledge.com/webinars/
                              Live Support available Join between 3:00 - 3:30 p.m. ET Monday - Thursday: https://clickandpledge.com/webinars/
                              Are you on Salesforce? Join us at the Power of Us Hub: https://powerofus.force.com/0F980000000CjpC

                              Comment

                              Working...
                              X