Announcement

Collapse

Information Needed

See more
See less

Recurring transaction suddenly not posting to salesforce

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • cliff.archey
    replied
    Thank you for taking care of this, and thank you for giving me a heads up on the uploading of images. I will keep that in mind in the future. For this particular order number, the issue has been resolved. I will let the forum know if the issue arises again at the end of this month when his recurring donation processes again.

    Leave a comment:


  • CnP.Support
    replied
    Good day @Cliff.Archey:

    Please be careful when you upload images to this forum. Uploading images that reveal your patrons full name and email is not a good idea when dealing with a public forum. It is always best to provide us with the Order number, first name, and last name initial and not their email or any other personal identifiable information. Thank you.

    I reviewed our system and see that the Order Number: 1372965025256011 has posted successfully to your Salesforce. Have you searched for this Order Number in Salesforce? I want to see if you find it in C&P Data and if there are any errors. Please note that you cannot push the data if C&P Data already has the transaction and that is why you don't see it in the Administrative Portal.

    Leave a comment:


  • cliff.archey
    replied
    Hello,

    I wanted to follow up on the recurring donation not posting to Salesforce. I was able to push the one-time donations from Click and Pledge to Salesforce from the ones missed last week, but am still not able to push James Amend's recurring transaction. Below is a screenshot with the transaction details and option I get when trying to push it. Thanks!

    Click image for larger version

Name:	Amend_recurring_CP.jpg
Views:	1
Size:	65.1 KB
ID:	15242

    Leave a comment:


  • cliff.archey
    replied
    Hello,

    Thank you for sending this along. I have granted you 1 week of access, so you should have no problem getting in. Please let me know if you have any questions in the meantime.

    Thanks,

    Cliff

    Leave a comment:


  • CnP.Support
    replied
    Good day @click.archey:

    Sorry for the delay in getting back to you. We had to research the issue you are having and figure out why you are seeing a different behavior. The new UI apparently is different. Please see if the following image helps:



    If the above works please grant 1 week access to our team so we can review your setting.
    Attached Files

    Leave a comment:


  • cliff.archey
    replied
    Yes, I am an administrator, which is why I was confused about the inability to grant access. Is this a different process with the newer editions?

    Leave a comment:


  • CnP.Support
    replied
    Good day!

    Are you an administrator for your Salesforce instance?

    Leave a comment:


  • cliff.archey
    replied
    Hello again,

    The updated package, version 7.4019 was installed. I have attempted granting you access to our account so that you can update applications to the latest release, but the screen I have is different than the one referred to in the video link you sent me, which I assume is from an older version. View the attached screenshot and you'll see I don't have the option to grant you access. Click image for larger version

Name:	Login Access Policies.jpg
Views:	1
Size:	147.5 KB
ID:	15234

    Leave a comment:


  • CnP.Support
    replied
    Good day @Cliff:

    Please update to the latest release following instructions as given by Salesforce:

    https://appexchange.salesforce.com/r...20%26%20Pledge

    You need to update the API Class Library & the Payment application.

    If you wish for us to upgrade your instance please grant us access to your account and we will upgrade your applications to the latest release. To grant us access please follow the steps listed in this KB article: https://forums.clickandpledge.com/showthread.php?t=1065

    Please let us know if we can be of any further assistance.

    Leave a comment:


  • cliff.archey
    replied
    Thank you. Our current version is 7.3006. Where do I update versions? I subscribed to the release notice forum, so thank you.

    I also attempted to push the donation to Salesforce, and it send me the following error message in my email: "Insert failed. First exception on row 0; firsterror: REQUIRED_FIELD_MISSING, Required fields are missing: [CnP_PaaS__Date_Established__c]:[CnP_PaaS__Date_Established__c]"

    It said the support team had been notified, but I updated all password information according to the forum posting you linked, so I'm not sure why it wouldn't be working. Any help you could give would be much appreciated.

    Thanks,

    Cliff

    Leave a comment:


  • CnP.Support
    replied
    Good day @cliff.archey:

    Please verify your release versions as shown below:

    click to enlarge
    Click image for larger version

Name:	PaaS_LatestRelease.jpg
Views:	1
Size:	179.0 KB
ID:	15232

    I logged into your account and found the transaction. The transaction shows as have failed to post to Salesforce and you can see this by following the KB article at: https://forums.clickandpledge.com/co...-to-Salesforce

    In your account the transaction shows as:

    click to enlarge
    Click image for larger version

Name:	Push_Transaction.jpg
Views:	1
Size:	93.1 KB
ID:	15233

    Considering the option for pushing to Salesforce is present it shows the item has failed to post.

    Once you push the transaction it will appear in your Salesforce.

    Also based on the date you stated in your email I believe your system is outdated and needs to be updated to the latest release. It may help if you subscribe to the following forum to stay up-to-date with the release notices: https://forums.clickandpledge.com/forumdisplay.php?f=54

    Please let me know if we can be of any further assistance.

    Leave a comment:


  • cliff.archey
    replied
    I tried the steps you outlined, and the order number is not located in Salesforce, despite being present in C and P. The order number is 1372965025256011. And I'm not sure which PaaS we're using. We installed it in April for the 2013 Salesforce nonprofit starter pack.

    Leave a comment:


  • CnP.Support
    replied
    Good day @cliff.archey:

    It is always best to tell us what version of PaaS you have installed so we minimize the number of posts. What is the version you are using?

    Have you checked the C&P Data? Have you searched the Order Number in the receipt and see if you can see it in Salesforce?

    Steps that will always help:
    1. Go to the email receipt and locate the Order Number (see image below)

      Click image for larger version

Name:	OrderNumber.jpg
Views:	1
Size:	8.3 KB
ID:	15230
    2. Go to Salesforce and search for the Order Number

      Click image for larger version

Name:	Salesforce-Search.jpg
Views:	1
Size:	11.6 KB
ID:	15231


    Does the search show any entries?

    The above simple steps will help us identify the issue.

    Looking forward to hearing back from you.

    Leave a comment:


  • cliff.archey
    replied
    Hello,

    We just ran into the same issue. We had a constituent subscribe to our monthly donation option through our API integration with Click and Pledge at https://www.nyfoundling.org/get-invo...onate-monthly/. His second month was processed in Click and Pledge, but does not show up in Salesforce. Is this a settings issue, or does something need to be fixed on the back-end?

    Thanks,

    Cliff Archey
    The New York Foundling

    Leave a comment:


  • CnP.Support
    replied
    Good day!

    Please see the following KB article:

    https://forums.clickandpledge.com/co...-to-Salesforce

    middle of the page there is a section about posting back to Salesforce the failed transactions: Post missing data to Salesforce

    If you don't see your transactions through the above method let me know so we can review your transactions.

    Leave a comment:

Working...
X