Announcement

Collapse

Information Needed

See more
See less

Unable to send email using Gmail's SMTP settings

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Unable to send email using Gmail's SMTP settings

    I have configured a new SMTP server under C&P Settings using my Gmail account (smtp.gmail.com, port 465, SSL enabled, my gmail address for login and my password) but after entering a test email address and clicking Verify, I always receive "SMTP connection failed. Please verify the information and try again.".

  • #2
    Good day

    Have you tried port 587?

    Please try that and let me know if it still does not work.
    Regards,
    Click & Pledge Support Department

    On Salesforce? Help us by rating our app: Click & Pledge Donor Management on AppExchange

    Join us @ the educational webinars: https://clickandpledge.com/webinars/
    Live Support available Join between 3:00 - 3:30 p.m. ET Monday - Thursday: https://clickandpledge.com/webinars/
    Are you on Salesforce? Join us at the Power of Us Hub: https://powerofus.force.com/0F980000000CjpC

    Comment


    • #3
      Yes, I tried 587. It still fails with the same message, but it fails within less time.

      Originally posted by Support.Department View Post
      Good day

      Have you tried port 587?

      Please try that and let me know if it still does not work.

      Comment


      • #4
        I tried port 587, but get the same error.

        Comment


        • #5
          Good day!

          Interesting finding so far. Here is what I did to find out what is going on with your account.

          Click image for larger version

Name:	SMTP_test.jpg
Views:	1
Size:	13.4 KB
ID:	15167

          SMTP: smtp.gmail.com
          Server port number: 587
          Enable SSL: True

          I set up a Test email address with Gmail with no settings or changes- simply the default account which is set up when you apply. Next I set up the SMTP with the above information and it worked perfectly. No issues.

          I also had other people at the company test it and they also had no problem with their own personal accounts.

          Next I tested it with my own account for which I have enabled 2 factor authentication. I have not been able to make it work since Gmail keeps posting an internal error for verification required.

          So that brings me to the question- is your account using a 2 factor authentication? Have you changed any of the Gmail settings?

          As I stated before a straight account with no setting changes worked perfectly.
          Regards,
          Click & Pledge Support Department

          On Salesforce? Help us by rating our app: Click & Pledge Donor Management on AppExchange

          Join us @ the educational webinars: https://clickandpledge.com/webinars/
          Live Support available Join between 3:00 - 3:30 p.m. ET Monday - Thursday: https://clickandpledge.com/webinars/
          Are you on Salesforce? Join us at the Power of Us Hub: https://powerofus.force.com/0F980000000CjpC

          Comment


          • #6
            That was the remaining issue, thank you. I have 2-factor authentication enabled for my Gmail account, but not for my Google Apps account. So it seems that using my Google Apps account along with port 587 works fine. The main issue was that everywhere I searched about using Gmail for SMTP indicated using port 465 with SSL. You should make it very clear to users that are using Gmail or Google Apps accounts for SMTP requires port 587.

            Comment


            • #7
              Good day!

              Frankly we were not aware of this. All of our tests were done with port 587 and had no idea other ports may be used.

              We will adding a comment to the next release and will add it to the manual.

              We all learned something new today.. undocumented features I guess!
              Regards,
              Click & Pledge Support Department

              On Salesforce? Help us by rating our app: Click & Pledge Donor Management on AppExchange

              Join us @ the educational webinars: https://clickandpledge.com/webinars/
              Live Support available Join between 3:00 - 3:30 p.m. ET Monday - Thursday: https://clickandpledge.com/webinars/
              Are you on Salesforce? Join us at the Power of Us Hub: https://powerofus.force.com/0F980000000CjpC

              Comment


              • #8
                Glad to help uncover this 'feature.

                After switching my autoresponders to use the Gmail SMTP setting, none of the emails appeared in the Autoresponder Log. How can I ensure they are being delivered using the new SMTP?

                Comment


                • #9
                  Good day

                  I am assuming that your SMTP setting verified when you added it.

                  Would you please edit the setting and verify it again making sure it is connecting and is able to send a test email.

                  If verified please check your gmail account and make sure you have received the test email.

                  Let me know if all the above works.
                  Regards,
                  Click & Pledge Support Department

                  On Salesforce? Help us by rating our app: Click & Pledge Donor Management on AppExchange

                  Join us @ the educational webinars: https://clickandpledge.com/webinars/
                  Live Support available Join between 3:00 - 3:30 p.m. ET Monday - Thursday: https://clickandpledge.com/webinars/
                  Are you on Salesforce? Join us at the Power of Us Hub: https://powerofus.force.com/0F980000000CjpC

                  Comment


                  • #10
                    Yes, the SMTP setting was verified and the test email was received. After verifying the test email was received, I changed the Autoresponder templates to utilize the new Gmail SMTP setting and then subsequently realized that receipt emails were not appearing in the Autoresponder Log. Since I am also not receiving BCC emails of receipts sent via Autoresponder (see separate thread), I have no way to ensure the emails have been sent short of asking donors if they received them, which is not ideal.

                    Comment


                    • #11
                      I went through the process to set this up again in case I missed something, sent a test email which was received, and then set the donation receipt template to use the Gmail SMTP settings. Still not seeing them in the Autoresponder log.

                      Comment


                      • #12
                        Good day!

                        This is quite strange since we have tested this over and over again and it works.

                        Could this be related to your other post with the changes in the WID filter?
                        Regards,
                        Click & Pledge Support Department

                        On Salesforce? Help us by rating our app: Click & Pledge Donor Management on AppExchange

                        Join us @ the educational webinars: https://clickandpledge.com/webinars/
                        Live Support available Join between 3:00 - 3:30 p.m. ET Monday - Thursday: https://clickandpledge.com/webinars/
                        Are you on Salesforce? Join us at the Power of Us Hub: https://powerofus.force.com/0F980000000CjpC

                        Comment


                        • #13
                          This issue is unrelated to the other post about WID filters. The only thing that I am changing in this scenario is the SMTP setting. With the salesforce setting I see emails in the auto responder log. With the Gmail SMTP setting I do not see them in the log after a donation is received.
                          Any other debug advice you can give would be helpful.

                          Comment


                          • #14
                            Good day!

                            Would you please follow the steps listed below and set up a user for us to review your settings:

                            http://forums.clickandpledge.com/showthread.php?t=1065

                            We need to login and review what is going on.
                            Regards,
                            Click & Pledge Support Department

                            On Salesforce? Help us by rating our app: Click & Pledge Donor Management on AppExchange

                            Join us @ the educational webinars: https://clickandpledge.com/webinars/
                            Live Support available Join between 3:00 - 3:30 p.m. ET Monday - Thursday: https://clickandpledge.com/webinars/
                            Are you on Salesforce? Join us at the Power of Us Hub: https://powerofus.force.com/0F980000000CjpC

                            Comment


                            • #15
                              Not sure if you saw my previous response on this, but you guys already have an account on our system for this purpose. Please let me know when you have had a chance to check out what's going on.

                              Comment

                              Working...
                              X