Announcement

Collapse
No announcement yet.

Bug Report - SMTP added to C&P Settings does not show up in autoresponder options

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • CnP.Support
    replied
    @ESwoers,

    Interesting & strange indeed. We will go ahead and test the combinations to see why this is the case.

    As stated we simply form the SMTP envelope with the options you check and connect to the SMTP server. It is 2 lines of code..

    I will keep you posted.

    Leave a comment:


  • esowers
    replied
    I did get this working. As I was entering the information I would enter the SSL port (port 465) and select the "enable SSL" button. However, with both of those options selected it would error out. If I entered port 465 and left the SSL unchecked then it would go through fine. Alternatively if I used another port and selected the "enable SSL" button it would also work.

    I'm not sure if it's worth making a note on that page that either one or the other should be selected.

    Thanks

    Leave a comment:


  • CnP.Support
    replied
    @ESowers,

    Any update on this? Did you manage to get SendGrid to work?

    Leave a comment:


  • CnP.Support
    replied
    @esowers;

    In reference to the image- we have noticed that this forum platform shows PNG files as thumbnails. It is best to post JPG as it is shown as full size.

    Leave a comment:


  • CnP.Support
    replied
    Good day!

    With SendGrid we use port 587 and it works fine. With our system we really don't do much of anything- we use the information provided and try to connect to the server and if it replies we will send the email.

    For all practical purposes if you can set it up with the information in Outlook or any email client and it works it should work for us.

    Try 587 and let me know if it works.

    Leave a comment:


  • esowers
    replied
    sorry, not sure why that image was so small.
    Attached Files

    Leave a comment:


  • esowers
    replied
    Ok, so I signed up for a sendgrid account to setup the SSL SMTP connection, however I'm getting the same error. Can you provide me with the information you use for Sendgrid?

    Attached is a screenshot of what I used and the error.

    Thanks
    Attached Files

    Leave a comment:


  • CnP.Support
    replied
    @ESowers,

    We just finished our test with non-SSL and it works fine. We tested it with Sendgrid and not Mandrill.

    The latest beta has the update.

    Please let us know if you manage to test it as well.

    Leave a comment:


  • esowers
    replied
    Yes, I did reference both of those posts when testing the SMTP settings. However, when trying to send a test email over port 465 (with SSL enabled) the test email errors out. If I switch to a non-ssl port then it works fine.

    Leave a comment:


  • CnP.Support
    replied
    Good day!

    I have seen that before as well with other providers. Have you tried other ports? see:

    Leave a comment:


  • esowers
    replied
    Thanks for looking into this!

    I'd actually prefer an SSL connection, however when I tried to add the Mandrill SMTP with SSL the test email errored out. (smtp server : smtp.mandrillapp.com and port 465 with SSL enabled). Is there something I'm missing when adding an SSL connection?

    Leave a comment:


  • CnP.Support
    replied
    Good day!

    While we have resolve this issue we do not have a way of testing it. We cannot use non-SSL emails and providers as they violate PCI mandates. Gmail and Outlook and Office365 all requires SSL and cannot send without it.

    As you are using non-SSL SMTP servers (not recommended) is it possible for you to test the new release and let us know if it works for you. The SMTP should show up but as stated we cannot test it with a server that can send an email over non-secure channel.

    Looking forward to hearing back from you.

    Leave a comment:


  • CnP.Support
    replied
    Good day!

    We reviewed the application and added the non-SSL SMTP to the list of displayed SMTP servers. In the version you are using only the SSL SMTP servers is being displayed.

    This issue has been addressed in 9.1001 release.

    Sorry for the inconvenience.

    Leave a comment:


  • esowers
    replied
    Login access has been granted.

    Leave a comment:


  • CnP.Support
    replied
    Good day @ESowers

    Please grant us login access and the Salesforce Organization ID. We need to review your account and figure out why this is happening as we cannot duplicate it here.

    Leave a comment:

Working...
X