I have added Mandrill as an SMTP server, however when going to the Autoresponder Settings and clicking the dropdown next to the "SMTP Sender" field, only "Click & Pledge" and "Salesforce" show as options. My SMTP server does not show as an option.

This was talked about with Kamran during a live support session.