Announcement

Collapse
No announcement yet.

Swiper1 not staying connected after initial successful testing

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Swiper1 not staying connected after initial successful testing

    We're using two Swiper1 readers at our multi-day theatre event. We've had an issue recur each day for 3 days in a row now whereby each Swiper1 reader appears connected in the mobile app, but the light is blinking on each reader, and either inserting or swiping cards isn't recognized.

    This is perplexing because before each day's performance, each Swiper1 is tested and working, each with a separate mobile phone (sometimes iPhone, sometimes Android). However, after the performance (about 2 hours later) each Swiper1 exhibits the issue above. This is a major problem because we solicit donations after performances, not before.

    We've tried two things:
    1) leaving each Swiper1 turned on during the performance, in hopes that it might retain the connection and work after the performance, and
    2) on a different day, turning off each Swiper1 during the performance and then turning it back on afterwards.

    Each approach resulted in the same issue.

    We've been careful to connect each Swiper1 to a separate mobile device. For example, Swiper1 A always connects to my iPhone, and Swiper1 B always connects to whatever 2nd mobile device is available that day (sometimes an iPhone, sometimes an Android phone).

    Is this a known issue? Any workarounds you might suggest?

  • #2
    We've had an issue recur each day for 3 days in a row now whereby each Swiper1 reader appears connected in the mobile app, but the light is blinking on each reader, and either inserting or swiping cards isn't recognized. << When you see that blinking, is that on a payment screen in Swiper1 App or Other screens?

    Would you please share the Swiper1 App Version# you are using? Also, please share the device details?

    Please note that the Swiper1 device will get switched off when it is idle for a certain time. Though it shows as connected upon switching on, the light still blinks until you go to the payment page.

    Regards,
    Click & Pledge Support Department

    On Salesforce? Help us by rating our app: Click & Pledge Donor Management on AppExchange

    Join us @ the educational webinars: https://clickandpledge.com/webinars/
    Live Support available Join between 3:00 - 3:30 p.m. ET Monday - Thursday: https://clickandpledge.com/webinars/
    Are you on Salesforce? Join us at the Power of Us Hub: https://powerofus.force.com/0F980000000CjpC

    Comment


    • #3
      When we see the light blinking, it is blinking on the Swiper1 device. On the mobile device, the Swiper1 app is open and on the checkout screen. The Swiper1 payment option is selected and the Device Manager shows the Swiper1 device connected. When the Process button is pressed, nothing happens.

      We are using version 9.001.014 of the iOS app. We also attempted using the latest available version of the Android app as of Friday 4/19. For mobile devices, we used several different ones, including an iPhone 7 with the latest iOS v12.2, another iPhone and an Android phone. I do not know the models of the other iPhone or Android phone because we utilize volunteers at our performances to accept post-show donations, and the phone models will vary from performance to performance.

      At our 2nd performance on Fri 4/19, we powered off the Swiper1 devices during our 2-hour performance, then after the performance powered them back on and verified in Device Manager that they were each connected to their respective mobile devices. We did not kill the app on our mobile devices during the performance.

      At our 3rd performance on Sat 4/20, we left the Swiper1 devices powered on during the performance, then after the performance verified in Device Manager that they were each connected. We did not kill the app on our mobile devices during the performance. From your statement "Please note that the Swiper1 device will get switched off when it is idle for a certain time. Though it shows as connected upon switching on, the light still blinks until you go to the payment page." I take it that the issue we experienced after our 3rd performance is a known issue.

      Comment


      • #4
        Though we have unable to replicate the exact scenario you have described, we have made some minor changes in our apps which might help you to get rid of the above issues. Hopefully going to be released in this week.
        Regards,
        Click & Pledge Support Department

        On Salesforce? Help us by rating our app: Click & Pledge Donor Management on AppExchange

        Join us @ the educational webinars: https://clickandpledge.com/webinars/
        Live Support available Join between 3:00 - 3:30 p.m. ET Monday - Thursday: https://clickandpledge.com/webinars/
        Are you on Salesforce? Join us at the Power of Us Hub: https://powerofus.force.com/0F980000000CjpC

        Comment

        Working...
        X