Announcement

Collapse
No announcement yet.

Connect Payment Form Nonfunctional

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Connect Payment Form Nonfunctional

    I had a legacy Click & Pledge donation page that was upgraded to Connect. The current Connect donation page is completely nonfunctional and I have not found any explanation as to why.

    I have both created a new Campaign in Connect and updated the default Campaign - each campaign uses the same settings, and has a different Payment Form. Both Payment Forms update whenever I make changes to the Campaign settings or the Payment Form itself, and the text boxes within the Payment Form allow the user to enter information, but the radio buttons for the payment options do not work (clicking them does not change the amount to be charged, and when a default option is set, clicking other payment option radio buttons does not change the amount from the default amount), and the submit form button does not work.

    None of the campaign settings or payment form settings appear to indicate that anything is wrong with the page. The page did not function last week, before I updated to ProPay, or now, after I upgraded - the same problems were evident in both cases.

    I feel like there's one simple solution that evades me but I can't find it.

    This is the payment form for my active, default campaign: https://connect.clickandpledge.com/w...9-2bd69db5c9d2

  • #2
    Your Monthly payment is set to the "Multiple". This does not mean what you think it means - "Multiple" payment refers to splitting your donation to apply to multiple funds. For example, churches might use "Multiple" to let their donors break up their $100 donation to donate $80 to the Mission Fund and $20 to the Building Fund.

    Click image for larger version

Name:	2020-08-19_18-12-18.jpg
Views:	27
Size:	59.5 KB
ID:	55165

    Change both one time and monthly to Multiple OR change both back to "Single", and include an 'Other' option if you'd like donors to set their own amount.

    I will bring this up with our team as a potential bug.


    You might also consider watching the Click & Pledge Overview webinar and the Get Started with Click & Pledge webinar to help you get used to CONNECT.
    Regards,
    Click & Pledge Support Department

    On Salesforce? Help us by rating our app: Click & Pledge Donor Management on AppExchange

    Join us @ the educational webinars: https://clickandpledge.com/webinars/
    Live Support available Join between 3:00 - 3:30 p.m. ET Monday - Thursday: https://clickandpledge.com/webinars/
    Are you on Salesforce? Join us at the Power of Us Hub: https://powerofus.force.com/0F980000000CjpC

    Comment


    • #3
      We also needed to reset the payment methods (American Express, Mastercard...) on your account. Your form appears to be functioning correctly now. If you are still experiencing the problem, be sure to clear your browser cache.

      Regards,
      Click & Pledge Support Department

      On Salesforce? Help us by rating our app: Click & Pledge Donor Management on AppExchange

      Join us @ the educational webinars: https://clickandpledge.com/webinars/
      Live Support available Join between 3:00 - 3:30 p.m. ET Monday - Thursday: https://clickandpledge.com/webinars/
      Are you on Salesforce? Join us at the Power of Us Hub: https://powerofus.force.com/0F980000000CjpC

      Comment

      Working...
      X