No announcement yet.

Can't edit forms in a specific campaign

  • Filter
  • Time
  • Show
Clear All
new posts

  • Can't edit forms in a specific campaign


    This is really bizarre and unexpected behavior. I just copied our default campaign and made some changes to the new campaign (custom questions, etc).

    I am not able to edit the forms associated with this campaign.

    I recycled the form from my default campaign. Can't edit.
    I tried creating a new form. Can't edit.
    I tried copying the default campaign another time. Recycled form from default campaign. This time, I can edit.

    I am still able to edit the form in the default campaign as well as other campaigns.

    What's going on here?!


    Account 60379
    Form with trouble: Scholarship Gift
    Second copy of default form that is working: Forms Test
    Last edited by jodina-mai; 01-22-2020, 09:36 PM.

  • #2
    Okay. This seems to be related to a conditional section I added. Custom Section 4 is conditional based on the answer to . When I removed the condition, now I can edit the form. Once I made the section conditional again, I can't edit the form again.
    Last edited by jodina-mai; 01-22-2020, 10:31 PM.


    • #3
      Okay. I figured out what is happening.

      When I created the custom questions, I pasted text that had an apostrophe into one of the question options that was used in the conditions. But it seems that you do not allow apostrophes in question option text. When I removed the apostrophe, now the conditional piece works.

      This should definitely be fixed! I shouldn't have been able to paste a value that would cause problems.

      And, also, I would strongly suggest allowing apostrophes! I'm trying to use possessive ("recipient's") in the option.


      • #4
        Good day @jodina-mai

        I have forwarded it to our developers to see the possibilities to allow the apostrophes in custom questions.
        Click & Pledge Support Department

        On Salesforce? Help us by rating our app: Click & Pledge Donor Management on AppExchange

        Join us @ the educational webinars:
        Live Support available Join between 3:00 - 3:30 p.m. ET Monday - Thursday:
        Are you on Salesforce? Join us at the Power of Us Hub:


        • #5
          Thank you. The second piece is that there should definitely be an error if you somehow get one in like I did - or at least explanatory language about punctuation! Or, if you paste text containing an apostrophe, it should be removed when the text is pasted (why is it possible to paste one but not type one in?).