Announcement

Collapse
No announcement yet.

Connect Temp Contact Error

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Connect Temp Contact Error

    When someone contributes via C&P Connect, but they are not already a contact in our SF instance, a temp contact is being created and cannot be processed into a new contact without getting an error message. Once you get that error message, a new contact is actually created, so now you have both a new contact and the temp contact. Those cannot be merged through C&P Temp Contacts because of the same error message saying Duplicate value found CnP_PaaS_VaultGUID_C.

    Screenshots attached.
    Attached Files
    Last edited by [email protected]; 01-24-2014, 09:15 AM.

  • #2
    Good day!

    Sorry for the trouble you are having. May we have access to your account to review the issue?

    Please post back the Salesforce Organization ID so we can find and login.
    Regards,
    Click & Pledge Support Department

    On Salesforce? Help us by rating our app: Click & Pledge Donor Management on AppExchange

    Join us @ the educational webinars: https://clickandpledge.com/webinars/
    Live Support available Join between 3:00 - 3:30 p.m. ET Monday - Thursday: https://clickandpledge.com/webinars/
    Are you on Salesforce? Join us at the Power of Us Hub: https://powerofus.force.com/0F980000000CjpC

    Comment


    • #3
      Thanks for the quick reply.

      Access Granted, ORG ID 00DA0000000aYkB

      We deleted the temp contact because we created everything manually, so you may need to send a test transaction through to replicate the error.

      Comment


      • #4
        Good day!

        We have tested your instance many times and posted new transactions with dummy Contacts that all went to the Temporary Contact. We then converted to the real contacts without any issues.

        The issue is the transactions appear to be in your Transaction list already and seems that you have posted these transactions again so they are duplicates. The error is stating that the transactions are already posted. Do you know if these contacts were cloned to posted again through the Portal? All evidence points in that direction.
        Regards,
        Click & Pledge Support Department

        On Salesforce? Help us by rating our app: Click & Pledge Donor Management on AppExchange

        Join us @ the educational webinars: https://clickandpledge.com/webinars/
        Live Support available Join between 3:00 - 3:30 p.m. ET Monday - Thursday: https://clickandpledge.com/webinars/
        Are you on Salesforce? Join us at the Power of Us Hub: https://powerofus.force.com/0F980000000CjpC

        Comment


        • #5
          That is the issue we are trying to resolve and it only occurs when the donation comes in through C&P Connect, not via our other checkout pages.

          Our first interaction with that transaction is typically from the C&P Temp Contacts panel, so to my knowledge, no one in our org is cloning a transaction prior to one of us attempting to convert the Temp Contact, has never been in our workflow.

          Any ideas on what could be causing this?

          Comment


          • #6
            Good day!

            This is strange- we are testing this and trying to figure out why you are seeing this behavior. Our tests are working without any issues but if you have not deleted a Contact and are getting this error we have to do more testing.

            I will keep you posted.
            Regards,
            Click & Pledge Support Department

            On Salesforce? Help us by rating our app: Click & Pledge Donor Management on AppExchange

            Join us @ the educational webinars: https://clickandpledge.com/webinars/
            Live Support available Join between 3:00 - 3:30 p.m. ET Monday - Thursday: https://clickandpledge.com/webinars/
            Are you on Salesforce? Join us at the Power of Us Hub: https://powerofus.force.com/0F980000000CjpC

            Comment


            • #7
              This happened again this morning...donation through our Connect account and you can see the progression of the error. I am the only person to login and do anything with this donation/temp contact, so there is nothing happening on our end that I am aware of...please advise and thanks for your help. I've granted access for one-week.

              Click image for larger version

Name:	Screen Shot 2014-01-28 at 9.29.53 AM.jpg
Views:	1
Size:	9.7 KB
ID:	15366Click image for larger version

Name:	Screen Shot 2014-01-28 at 9.30.11 AM.jpg
Views:	1
Size:	21.2 KB
ID:	15365Click image for larger version

Name:	Screen Shot 2014-01-28 at 9.30.44 AM.jpg
Views:	1
Size:	18.2 KB
ID:	15364Click image for larger version

Name:	Screen Shot 2014-01-28 at 9.31.20 AM.jpg
Views:	1
Size:	20.9 KB
ID:	15363

              Comment


              • #8
                Hi Tom,

                Thank you for your post. We have identified the problem and it is a bug that will be resolved with the next Salesforce update.

                The issue lies with Salesforce campaign being set up but no fundraiser campaign. PaaS has problem setting up the campaign chain. The problem may be resolved, in the interim, if you set up a fundraiser campaign. We have found the issue after testing all possible cases and duplicating your setting.

                Sorry for the inconvenience. The update will resolve this. It is currently scheduled for February 15 - if not earlier.
                Regards,
                Click & Pledge Support Department

                On Salesforce? Help us by rating our app: Click & Pledge Donor Management on AppExchange

                Join us @ the educational webinars: https://clickandpledge.com/webinars/
                Live Support available Join between 3:00 - 3:30 p.m. ET Monday - Thursday: https://clickandpledge.com/webinars/
                Are you on Salesforce? Join us at the Power of Us Hub: https://powerofus.force.com/0F980000000CjpC

                Comment

                Working...
                X