Announcement

Collapse
No announcement yet.

Autoresponder not working

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • CnP.Support
    replied
    Great!

    Glad to see all is working now.

    Please let us know if we can be of more assistance.

    Leave a comment:


  • mkavodah
    replied
    Solved it! Needed to be Online Donation = TRUE. Thanks!

    Leave a comment:


  • mkavodah
    replied
    I made that change and it's still not working. I looked through the transaction info and see <SendReceipt>false</SendReceipt>. Where is that setting coming from? Could that be the final problem?

    Leave a comment:


  • CnP.Support
    replied
    Good day!

    Please see:

    Click image for larger version

Name:	AutoResponder.jpg
Views:	43
Size:	18.2 KB
ID:	22756

    and the posted data:

    Click image for larger version

Name:	CnP-Data.jpg
Views:	36
Size:	16.5 KB
ID:	22757

    As you see the filter for the custom question IS "ONLINE"

    The Data posted is: "Online Donation"

    In your filter you have NO SPACE and in the posted data you have SPACE. The filter searches for the text and in this case it will not find a match due to the space.

    Hope you see the issue.

    Let us know if you need any further help.

    Leave a comment:


  • mkavodah
    replied
    I changed that (I think) and tried another, and still didn't get a receipt. Transaction number 1603231730153961111. Thanks for these quick replies!

    Leave a comment:


  • CnP.Support
    replied
    Good day!

    I just reviewed one of your Order Numbers and in the C&P Data I see:

    Click image for larger version

Name:	2016-03-23_17-24-59.jpg
Views:	34
Size:	33.5 KB
ID:	22750


    Please note that no campaign is not met with NOT INCLUDES. For it to have that filter it has to have a value. A NULL value is ignored.

    The BLANK condition is for this scenario.

    I have not checked the rest but if others are similar then it makes sense as to why it is not being sent.

    Leave a comment:


  • mkavodah
    replied
    1603231552566301111
    1603231551074831111
    1603231548345331111
    1603231546304631111
    1603231544598901111

    Those are all test transactions from today with me playing with various combinations of settings.

    Leave a comment:


  • CnP.Support
    replied
    Good day!

    Do you have an order number that should have triggered the autoresponder & did not?

    Leave a comment:


  • mkavodah
    replied
    Done. Org ID is 00DG0000000iirz.

    I'm not quite sure if I have the Campaign condition correct. I'm trying to exclude gifts to the Events we have set up, as those already get thank yous. In other words, I want these to go as long as the Campaign isn't one of the two I have there. Don't think that's what's causing the problem, but as long as you're in there

    Thanks!

    Leave a comment:


  • CnP.Support
    replied
    Good day!

    Please grant us login access so we can review.

    Leave a comment:


  • mkavodah
    started a topic Autoresponder not working

    Autoresponder not working

    Hi,

    I can't get our autoresponder working. This is our first effort at trying to use it. In the Portal, I have Do Not Send Receipt = No. In Salesforce C&P settings I have the autoresponder status as Active. I tried going through and taking out each of my conditions one by one to see if they were the problem. I've also tried the Mail From address as both [email protected] and an email in our domain. None of this has gotten it going.

    Our donation form is custom rather than a C&P one, if that makes a difference. I've also been trying with our donation page in test mode.

    Help? For the moment I'm going to deactivate in case it suddenly starts firing without me getting a chance to test.

    Thanks!
Working...
X