Announcement

Collapse
No announcement yet.

declined transaction

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • declined transaction

    I'm sorry for burdening you, but I don't know another way to research these things. A donor by the name of Kim J. has tried twice recently to donate using the same card she has used in the past, but now is getting a decline error. The most recent order number is 1409122248558169709. What is the reason code in this case?

  • #2
    Good day!

    You will be happy to learn that the new features that are being added to Connect will give you all the information you need about every transaction. I will not go into more details but the fraud options are being worked on with great granularity.

    Of course this case would still be problematic.

    This is the same as your other mode: Decline Test Transaction

    I believe we have a major problem. Do you wish for us to review your form?

    The payment was made in TEST mode.
    Regards,
    Click & Pledge Support Department

    On Salesforce? Help us by rating our app: Click & Pledge Donor Management on AppExchange

    Join us @ the educational webinars: https://clickandpledge.com/webinars/
    Live Support available Join between 3:00 - 3:30 p.m. ET Monday - Thursday: https://clickandpledge.com/webinars/
    Are you on Salesforce? Join us at the Power of Us Hub: https://powerofus.force.com/0F980000000CjpC

    Comment


    • #3
      Really? I was sure this was a different problem. This is cut from the XML data:
      <TransactionDetail>
      <OrderNumber>1409122248558169709</OrderNumber>
      <TransactionID>2774024</TransactionID>
      <OrderMode>Live</OrderMode>

      I'm happy to hear about these new features. Will we have to use the Connect platform to take advantage of the fraud options and transaction information?

      Please do review our form. We've made substantial improvements recently, but maybe we missed something.

      Thank you.

      Comment


      • #4
        Good day!

        You are referencing WID= 76419

        <CheckOutPageID>76419</CheckOutPageID>

        This checkout page is in TEST mode.

        I reviewed your account and noticed:

        yellow border indicates TEST mode
        Click image for larger version

Name:	2014-09-14_11-55-39.jpg
Views:	1
Size:	65.4 KB
ID:	15534

        The page shows TEST mode
        Click image for larger version

Name:	2014-09-14_11-56-03.jpg
Views:	1
Size:	60.8 KB
ID:	15535

        While your code is posting as LIVE the reference page is set to TEST mode. This is designed so you can test without having to work with the developer to make changes to your site.

        I will review the reason LIVE is being posted to Salesforce. The integration services sends the raw data posted to it by the form but it should show what actually is happening- we will fix this.

        I fixed your page and change it to live just in case you can't fix this now considering your site is live.

        Please let me know if we can be of any further assistance.
        Regards,
        Click & Pledge Support Department

        On Salesforce? Help us by rating our app: Click & Pledge Donor Management on AppExchange

        Join us @ the educational webinars: https://clickandpledge.com/webinars/
        Live Support available Join between 3:00 - 3:30 p.m. ET Monday - Thursday: https://clickandpledge.com/webinars/
        Are you on Salesforce? Join us at the Power of Us Hub: https://powerofus.force.com/0F980000000CjpC

        Comment


        • #5
          Correct me if I'm wrong, but the status of the form builder doesn't affect FaaS pages. I've been running in Live mode for 3 months, so this is a problem with just these two people: Kim J. and Keith C.

          Keith C. tried again on Saturday evening with the same result: Declined.

          Comment


          • #6
            Good day!

            Sorry but I gave you the wrong information- the WID status is not related to your issue. When you posted the C&P Data showing the LIVE I thought that should be the reason. The WID status does not change the status as posted by FaaS.

            I researched the transaction and here is the XML posted to us:

            <OrderMode>Test</OrderMode>

            This is also in TEST mode.

            We just updated the Integration Services to fix the bug you reported. The bug is related to Declined transactions in Test mode which were being posted as Live to Salesforce. This bug has been fixed and will now show Test as it should be.

            Please send me the link to your form so I can review it.
            Regards,
            Click & Pledge Support Department

            On Salesforce? Help us by rating our app: Click & Pledge Donor Management on AppExchange

            Join us @ the educational webinars: https://clickandpledge.com/webinars/
            Live Support available Join between 3:00 - 3:30 p.m. ET Monday - Thursday: https://clickandpledge.com/webinars/
            Are you on Salesforce? Join us at the Power of Us Hub: https://powerofus.force.com/0F980000000CjpC

            Comment


            • #7
              The URL is https://www.ywamsf.org/donate. We also use https://www.ywamsf.org/payment.

              Comment


              • #8
                Good day!

                We reviewed your forms and they are OK and reviewing your account also shows that transactions are coming through without any issues.

                It seems like the 2 patrons posted earlier were using the cached version of your form when it was in TEST mode. I can't think of any other reason for this.

                I had 2 of our developers review your forms and they can't find any issues. Strange indeed.
                Regards,
                Click & Pledge Support Department

                On Salesforce? Help us by rating our app: Click & Pledge Donor Management on AppExchange

                Join us @ the educational webinars: https://clickandpledge.com/webinars/
                Live Support available Join between 3:00 - 3:30 p.m. ET Monday - Thursday: https://clickandpledge.com/webinars/
                Are you on Salesforce? Join us at the Power of Us Hub: https://powerofus.force.com/0F980000000CjpC

                Comment


                • #9
                  I agree, it is strange. I spoke with one of the two donors last week and I suggested he do a browser refresh (F5). I had thought that would reload the file from our site, but I learned today that it does not. For the benefit of others reading this, Ctrl-F5 bypasses the cache on most browsers. (http://en.wikipedia.org/wiki/Wikiped...ass_your_cache) I forwarded this on to the two donors. Hopefully it will solve the problem.

                  Comment

                  Working...
                  X