Announcement

Collapse
No announcement yet.

Prestashop Integration module not working properly

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • CnP.Support
    replied
    Good day!

    We have spent a lot of time with this issue. Here is what we have done:
    1. Reviewed your instance and have determined that the issue had started on 4/12/2013 -11:59:57
    2. We copied the PrestaShop code and set up a new database on your server and all works correctly as expected. [http://<REMOVED FOR POST>.org/test-store/index.php - please replace "<REMOVED FOR POST>" with your domain]
    Have you done anything to your instance on 4/12/2013 - 4/15/2013? It seems like a few files in the Config folder were changed on that date and we can't figure out what has been done to them but whatever has been done is causing this issue. Our test shows that your instance has the same problem regardless of what payment method is used.

    We researched the PrestaShop's forum and also found similar issues:Unfortunately we are stuck at this time and can't figure out what setting may have caused this. All we know is that our application is not the culprit and it is working. Please test it with the test setup we have set on your server and you will see that it is working perfectly. Somehow a setting you have changed on 4/12 is causing this and we can't figure out what it is.

    I hope you can find it with PrestaShop's help - we continue our research but if you find out anything please post it here as well for reference.

    Please let us know if you wish for us to remove the test store we set up for you.

    Leave a comment:


  • Guest's Avatar
    Guest replied
    Hello,

    I just created a support ticket that includes all the relevant information.

    Thanks.

    Leave a comment:


  • CnP.Support
    replied
    Good day!

    Please do not post the MYSQL in the forum since this is a public forum and the info you are referring to is extremely confidential. You may send it to us by creating a support ticket.

    The issue is the transaction information is not being inserted in the Order table. If you review the transaction you will see the order is blank for the transaction.

    Please create the support ticket with the info so we can review it.

    Leave a comment:


  • Guest's Avatar
    Guest replied
    Hello,

    I am on the phone with Prestashop now looking at the MYSQL database and he says it would be helpful to know what the exact error is that you are receiving. If you are seeing an error, can you provide the exact description/code/text?

    I'm thinking at this point it would be most helpful if you and Prestashop could talk directly. Is there anyway you can contact Robert at 888-947-6543? My support ticket is #670. He has all the access info for the MYSQL database.

    Leave a comment:


  • Guest's Avatar
    Guest replied
    Access to MYSQL Database

    I would like to provide you access to the MYSQL database so you can test further, but prefer not to post the access info online here. Can I send someone a direct email? Please advise.

    Leave a comment:


  • CnP.Support
    replied
    Good day!

    We have done several test transactions at your instance and have noticed that the problem is with inserting data into the Orders table in the database.

    The following line is where the problem is being caused:

    $authorizeaim->validateOrder((int)$cart->id, _PS_OS_PAYMENT_, (float)$post->x_amount, $authorizeaim->displayName, $message, $transation_number, NULL, false, $customer->secure_key);

    The issue could be due to permission issues with the database. We don't have access to the database and our access is purely to your admin and code. If you wish for us to investigate this further we need to have access to the MySQL database. The issue is not with our code since our test with other gateways in your instance has resulted in the same error. Of course they may be other issues or reasons for the failed insert but the only logical reason, at this time, is permission.

    Please let us know if we can be of any further assistance.

    Leave a comment:


  • Guest's Avatar
    Guest replied
    See attachment

    See attachment which shows failure to validate payment status.

    Leave a comment:


  • Guest's Avatar
    Guest started a topic Prestashop Integration module not working properly

    Prestashop Integration module not working properly

    Hello,

    Our C&P integration module with Prestashop is no longer working properly. I've spent a total of about 3.5 hours on the phone with Prestashop's tech support and this is the conclusion they've come to.

    We have a couple things happening:
    1. Many payments go through successfully and a receipt is emailed, however due to a failure to validate correctly within Prestashop, no order confirmation page is displayed... just a blank white screen.
    2. Several folks are experiencing double payments... it's unclear whether the system is generating the duplicate, or if they are doing it since they fail to receive a confirmation the first time.


    We are only running the store for two more weeks, but we have heavy promotion happening right now and really need to get this working properly. HELP!!

    Can you please look at the payment module and see if there's an update needed for it to talk to prestashop successfully. My prestashop technical support ticket is #670 and I've been working with Robert at 888-947-6543.

    Help!
Working...
X