Announcement

Collapse
No announcement yet.

Test Form

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • rtania
    replied
    Fixed the problem. I was missing some item code.

    Leave a comment:


  • rtania
    replied
    err=the%20basket%20is%20empty&hashresponse=zgezowe zzwu1ztzingjkmzi1nwjmzwy5ntywmtg5mgfmzdg3oq==&refi d=example-002
    Why does it say the basket is empty on my form?

    I added the account number, the WID, and the GUID.


    Leave a comment:


  • CnP.Support
    replied
    Good day!

    As the error is stating: Invalid Account

    I reviewed your page and see no nodes for account and other required fields.

    Please see this example: https://www.clickandpledge.com/Platf...s/example/002/

    A number of observations:
    • OnSuccessURL, OnDeclineURL, and OnErrorURL are missing
    • Account Number is missing
    • WID is missing
    • GUID is missing

    Please see the highlighted lines from the example posted above:
    Click image for larger version

Name:	2575-MissingNodes.jpg
Views:	102
Size:	160.7 KB
ID:	15746

    Please review the example and make sure all the required fields as indicated in the manual are present.

    See the following KB articles: http://forums.clickandpledge.com/content.php?r=480-faas

    Of importance is the one one how to start with FaaS: http://forums.clickandpledge.com/con...rted-with-FaaS

    The ERROR posted back in the URL is descriptive and shows you exactly what the error is. Simply remove the %20 (space) and the error will be self explanatory.

    Let us know if we can be of any further assistance.

    Leave a comment:


  • rtania
    replied
    Why do I get this message when I submit my form?
    err=invalid%20account&hashresponse=zgezowezzwu1ztz ingjkmzi1nwjmzwy5ntywmtg5mgfmzdg3oq==&refid=

    Do I get that message because I need to add an expiration drop down menu with month and year?

    Thank you



    Leave a comment:


  • CnP.Support
    replied
    Good day Tania,

    Sorry but I am a bit confused. This form does not follow our API in any shape or form. It seems like you have taken a form you were using before and simply changed its post link.

    A form cannot be expected to work just by posting it to a site. Each form field has to follow the standards of the API and validations appropriate to its schema.

    Have you seen any of our examples?

    - http://clickandpledge.com/Platforms/...ment/API/FaaS/

    You may see our API field names in the manual:

    - http://manual.clickandpledge.com/Form-Field-Names.html

    There are examples that you may download and review.

    Once your form is set using our standards we can go ahead and test it. While testing please make sure to set the OrderMode=Test

    You may also want to review the following KB article:

    - http://forums.clickandpledge.com/content.php?r=480-faas

    Please let us know if we can answer any questions you may have.

    Leave a comment:


  • rtania
    started a topic Test Form

    Test Form

    I got a form from a form builder site. Then I put method="post" and action="https://faas.cloud.clickandpledge.com"
    Is this right?
    http://www.operationshoestring.org/donate/
    Can somebody please check the form to see if it is working ok.

    Thank you,
    Tania
Working...
X