No announcement yet.

PaymentType set to "check" not working.

  • Time
  • Show
Clear All
new posts

  • PaymentType set to "check" not working.

    Hello again,

    Our form (now accessible without login requirements) at, has the option to pay by credit card or by check. Credit card works fine, but when someone selects "Check", the error URL is returned.

    In the form page, some JavaScript is setting the value of the <input> tag for name "PaymentType" to the selected payment method. I have added an "alert" to check that the value is indeed set. But no matter, the result is an error.

    Could you please help me discover the problem? What else needs to be set in the form to process checks? Is there some field missing? Or some other data that needs to be present for a check to be processed? I don't know what's going on here, so I appreciate any help.

    Thank you!


    EDIT/UPDATE: The error that's returned is "Invalid Account". What does this mean? Does it ,mean that our C&P account is not equipped to deal with checks? If so, how to rectify that? Where in C&P should this payment method be activated?

    Or, does it mean that we need to capture a person's ID as well? In the "Form Fields" documentation for FaaS, these fields are listed but no indication is given whether they're required to be populated for a check transaction. How does one know what gateway is being used for checks?

    Last edited by Lew; 09-01-2015, 10:48 PM.

  • #2
    The check mode is still not working.

    I found the bug in my form that caused the paymenttype to post as "Check,Check", after speaking with Kamran today during office hours. I fixed this bug and ran the form through the C&P verification URL. It does not show any evident errors. But when I try to run the production version of the form with a check transaction, it still comes back with "Invalid Account".

    So I don't know what's going on. There's nothing that's obviously wrong in the verification page: all values are set to correct values. Yet the transaction is rejected.

    This is a real problem now because we have a couple of check transactions pending to be processed, but cannot because the form isn't working, and I don't know what else the problem is.

    Could someone please help and show me where the problem now lies?



    • #3
      Good day!

      Would you please send us the link to the TEST form as pointed to the - we need to review the result of your post to determine what you are posting.

      it is practically impossible to debug someone else's code. We can review your posts and let you know what you are posting and what it should be. Once we know the invalid post we will be able to point you in the right direction.

      Please let us know the URL to the test site so we can review.
      Click & Pledge Support Department

      Join us @ the educational webinars:
      Live Support- read more:


      • #4

        Yes, I understand the problem as I am a software developer trying to make sense of FaaS. But when I send the form to your "verify" URL and can't see anything wrong, and your error message is cryptic and uninformative, then I don't have much in the way of options. Here's the URL of the TEST form; it's identical to the form in production now, except the mode ("Test" instead of "Production") and action URL.

        No login requiired.

        This vBulletin seems to be eating links; here it is again ""

        Thank you!
        Join us! We are an essential source of insight and inspiration to more than 300 financial women throughout the Bay Area.
        Last edited by Lew; 09-03-2015, 08:05 AM.


        • #5
          Hi Lew,

          We reviewed your code. Here is one problem.

          You have listed in your form the following information for Account and GUID:
          • AccountGUID: 33f1baa7-**************-f2cdc258d554
          • AccountID: 25687
          The form you sent us for account # 25687 has a different GUID- see the image below:

          Click image for larger version

Name:	2015-09-03_10-32-03.jpg
Views:	43
Size:	61.9 KB
ID:	18895

          The GUID you are using for this account is not correct. No such account exists in our system.

          May I ask what account is your intended target for this form?
          Click & Pledge Support Department

          Join us @ the educational webinars:
          Live Support- read more:


          • #6
            Ah, wow - OK, that makes sense. The account is definitely 25687. It was 25686 initially but had to change for proper accounting. And so I changed the Account ID but not the GUID.

            So all I need to do is replace the current GUID with the correct one for 25687, yes?

            Thank you - this would have taken me a long time to discover!


            • #7
              Good day @Lew,

              Yes - please login to the Portal and change the value with what is for the account.

              The way we found the issue was by copying your form to our local servers and changing the account info so we can test it. Once changed the form worked. So we started back tracking...

              Please test and let us know how it works.
              Click & Pledge Support Department

              Join us @ the educational webinars:
              Live Support- read more: