Announcement

Collapse
No announcement yet.

Undefined Constant Error

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • CnP.Support.AM
    replied
    Good day @mirrorstage

    Please submit a support ticket at https://support.clickandpledge.com/s/ with FTP and Admin login details as well as the website URL so we can review your entire configuration. Include the link to this post in the ticket for reference and add 'Attn: Forums' in your case subject line.

    Please let us know when you have submitted the ticket. Do not post the requested information in this forum as this is a public forum.

    Leave a comment:


  • mirrorstage
    started a topic Undefined Constant Error

    Undefined Constant Error

    We have had the WordPress Connect plug in for several years, and in late December, the form wasn't showing up correctly on our web site.While trying to debug, I deleted the existing Form group and Account from the database, and re-installed the newest plug-in update.

    I am able to install the and activate the plug-in (after removing the extraneous "/" on line 92 of clickandpledge_form.php), and when I try to re-enter our organization info in Settings, it recognizes the C&P Account # and the GUID and brings up the correct nickname when I click Verify, but when I try to save, I get the following error:
    WordPress version 5.9
    Current theme: Neve (version 3.1.4)
    Current plugin: Click & Pledge Connect (version 02.2112010000-WP5.8.2)
    PHP version 8.0.14

    Error Details
    =============
    An error of type E_ERROR was caused in line 407 of the file /home/mirrorst/public_html/wp-content/plugins/click-pledge-connect/Functions/functionscnp.php. Error message: Uncaught Error: Undefined constant "txtcnpacntid" in /home/mirrorst/public_html/wp-content/plugins/click-pledge-connect/Functions/functionscnp.php:407
    Stack trace:
    #0 /home/mirrorst/public_html/wp-content/plugins/click-pledge-connect/cnpSettings.php(49): CNPCF_addSettings('wp_cnp_forminfo', Array)
    #1 /home/mirrorst/public_html/wp-includes/class-wp-hook.php(307): cnp_formssettings('')
    #2 /home/mirrorst/public_html/wp-includes/class-wp-hook.php(331): WP_Hook->apply_filters('', Array)
    #3 /home/mirrorst/public_html/wp-includes/plugin.php(474): WP_Hook->do_action(Array)
    #4 /home/mirrorst/public_html/wp-admin/admin.php(259): do_action('click-pledge_pa...')
    #5 {main}
    thrown

    I have tried deleting and re-installing the plug-in several times and continue to get the same error. Please help!

    Thanks,

    Suzanne

Working...
X