Announcement

Collapse
No announcement yet.

Having trouble setting campaign, disabling custom fields, and found one potential bug

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • CnP.Support.AM
    replied
    Good day @Adam

    We suggest you to set the Transaction Campaign in Gravity Form. You may set "Giving Tuesday(GT)" as Transaction Campaign, this way it will differentiate the Product and Transaction Campaign in SF.

    Leave a comment:


  • Adam
    replied
    Cool, got it. One final thing:

    What is the proper way to format the Campaign Name? Should I simply use the Campaign Name ("Giving Tuesday") or format it with the Campaign Alias as well ("Giving Tuesday(GT)")? I ask because of how the selection is shown if I were to manually set the campaign in the Connect Transactions view. (See attached screencap.)

    Also, I noticed the "Transaction Mode" was set as "Production" there even though my CnP GF settings are for Test Mode. Is that normal?

    Leave a comment:


  • CnP.Support.AM
    replied
    Good day @Adam

    You are all set. However, Transaction Campaign can be set in Gravity Form but it is all your wish.

    Please refer to the manual: http://manual.clickandpledge.com/Gravity-Forms.html

    Hope that answers your question. Let us know if we can be of any further assistance.

    Leave a comment:


  • Adam
    replied
    Ok. And is the "Transaction Campaign" something that can be set with the Gravity Form? Or am I looking good with everything?

    Thank you so much for delving into this!

    Leave a comment:


  • CnP.Support.AM
    replied
    Good day @Adam

    The Campaign which you are referring to in the above image is Transaction Campaign but you have assigned the Product Campaign in your instance which doesn't appear on the Connect Transactions view.

    Hope that answers your question. Let us know if we can be of any further assistance.

    Leave a comment:


  • Adam
    replied
    Why is the campaign blank when I view recent transactions? (See attached image.) Is that normal?

    Leave a comment:


  • CnP.Support.AM
    replied
    Good day @Adam

    We reviewed your instance and the XML of above two order numbers which you are referring to. We don't see any issues with Campaign as we can see the Campaign included in the XML:

    Order#1610181114063851111

    Click image for larger version

Name:	1610181114063851111.jpg
Views:	31
Size:	71.3 KB
ID:	28004

    Order#1610181121560691111

    Click image for larger version

Name:	1610181121560691111.jpg
Views:	30
Size:	73.3 KB
ID:	28005

    Please check and let us know if we can be of any further assistance.

    Leave a comment:


  • Adam
    replied
    Perfect! You should now have access, and the Salesforce Organization ID is 00Di0000000HYFd. Looking forward to what you can find!

    Leave a comment:


  • CnP.Support.AM
    replied
    Good day @Adam

    How to grant access:

    Leave a comment:


  • Adam
    replied
    Organization ID = 23966

    What is the recommended method for granting you login access to my Salesforce instance?

    Leave a comment:


  • CnP.Support.AM
    replied
    Good day!

    Would you please grant us login access to your Salesforce instance and share the Organization ID?

    Looking forward to hearing back from you.

    Leave a comment:


  • Adam
    replied
    Thank you for looking into everything! You may want to clarify the radio option scenario in the manual for setting the campaign:

    http://manual.clickandpledge.com/Gra..._for_a_Product

    I imagine that's a fairly common setup. Makes sense though that if the SKUs need the option variables, the campaigns should as well!

    I've updated my form with the missing values, but the campaign is still not being set. Perhaps I am listing the wrong name? I'm not sure. The Campaign Name is "Giving Tuesday" but I'm not sure if I should be using that or the Campaign Alias ("GT") or a combination "Giving Tuesday(GT)". The SKUs look good. Maybe this is an issue with using the "Other" custom amount field? Recent order numbers in my account to look at are 1610181121560691111 and 1610181114063851111.

    Leave a comment:


  • CnP.Support.AM
    replied
    Good day @Adam

    We reviewed your instance and noticed that you have NOT set the values for the product options which is causing the issues. Please note that in Gravity Forms for Products with options (eg: Radio button, drop down menus) there must be value added Eg: {CAMPAIGNNAME}{FIELDID=6}{OPTION=1000}. As you have set the Values for SKU's, same way you need to enter the values for product options.

    It is not possible to restrict/disable the Custom Question the way you want. However, in your case we suggest you to use other fields as shown below:

    Click image for larger version

Name:	fields.jpg
Views:	33
Size:	29.8 KB
ID:	27851

    Using red colour fields highlighted above, you can set the custom questions, which will not send to our API.

    Regarding the issue with Confirmation page, we have identified the issue and hopefully will address in our upcoming release. Sorry for the inconvenience.

    Hope that helps. Please check and let us know if we can be of any further assistance.

    Leave a comment:


  • Adam
    replied
    Ticket has been submitted! And by disabling custom fields, my situation is that I have a few single-line and paragraph text boxes being used in the donation form for special purposes. They do not need to be sent over to Click & Pledge. I was thinking it would be better to keep that data exclusive to WordPress. Since it seems like there is no existing ability to prevent specific data from being included with the rest, maybe a feature request would be that adding a class to the field prevents it from being sent? (Like "cnpskip" or something like that.)

    Leave a comment:


  • CnP.Support.AM
    replied
    Good day @Adam

    Would you please elaborate little about disabling custom fields?

    However, please submit a support ticket at http://help.clickandpledge.com with FTP and admin login details as well as the website URL so we can review your entire configuration. Include the link to this post in the ticket for reference.

    Please let us know when you have submitted the ticket. Do not post the requested information in this forum as this is a public forum.

    Leave a comment:

Working...
X